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Foreword 
S-PM 2102001

Dear Reader, 
Here is this  “SE (Subtitle  Edit)  – Technical  Report” to enrich the collection of Reports so far

produced2 under  the  same  basic  principles  characterizing  this  whole  testing  and  documentation
production. 
That is, in summary:  

 All what you'll read here is the result of a test & documentation project carried on in fair 
collaboration with the related s/w producer but, nevertheless, in total independence from him. 

 Besides  positive  technical  documentation  and  instructions,  also  our  possible  doubts,
perplexities and difficulties have been here fairly reported. 

 Technical  dialogue with  you is  strongly  encouraged,  to  the  obvious  benefit  of  all  involved
parties. To some extent we'll measure the effectiveness of this Report by the amount of feed-
back originated, as an evidence of the active role that the user community of such advanced s/w
products,  as  SE is,  should  be  entitled  to  play.  Active  role  that  we  strongly  advocate  and
welcome. 

Throughout this Report you'll happen to read some non-impersonal statements, such as in the following
“Viewpoint” section. 

Viewpoint 
As an overall assessment, to date, SE can be compared to a rough diamond, precious, rich in facets

and a little indecipherable. Still waiting to be scrapped and cleaned in order to highlight its full value. 
□

Non-impersonal  statements—in  contrast  with  the  customary  impersonal  authoring  of  technical
documentation—here expressed by the pronoun “we”. Well, it's that our purpose, and ambition, is to
speak and operate on behalf of the Users' community, this the reason. Your feed-back also about such
ambition is welcome.

The Author 

-<>-

1 Section marker [§], with:  “S-PM” short for “Studio-PM” and “yymmdd” as date-code. Sections with a more recent 
date-code are intended to supersede older ones. <!> This is how this Tech.Report will be selectively updated. 

2 See at: https://app.box.com/s/oao1kv62t2hct18scc3t 
 https://eric-ide.python-projects.org/eric-documentation.html 
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Essentials 
S-PM 210200

Essential  reference  data,  so  to  precisely  identify  the  product  we  are  talking  about,  its  hosting
environment, prerequisites, and execution procedure. 

Version Reference

Nr Item Version Note

1 Microsoft Windows 10  2004 Build 19041.867 
 (64 bit) 

Host Operating System 

2 Microsoft Windows 7  6.1 Build 7601:S.P.1 
 (32 bit) 

Alt. Host Operating System

3 Subtitle Edit  3.6 Program, main version 

Subject “Subtitle Edit – Technical Report”, short form:  “SE-TR” 

Prerequisite Standard operating system, as here listed, both 64 or 32 bit; 
then such SubtitleEdit-3.6.0-Setup.exe downloaded from https://www.nikse.dk web site. 
Nothing else. 

Execution Just after setup execution, SE is immediately up and running. Possible further setting, 
tuning and add-on will be described hereafter in this Report, where and when 
required. 
 Particularly relevant is the Video player on which SE will rely [see sct.:  Video 
Command Menu \ Requisite]. 

□

What & Where in the Internet 
SE  Program Home:  https://www.nikse.dk 

Docs:  <ToBeCompleted> 
Contact: nikse.dk@gmail.com 

S-PM  Report Storage:  Box, Inc. 
Deliver (“AsIs”):  https://app.box.com/s/4fcab4qbwbj520y09z3tjkv4jen7gc30 
Contact:  Studio-PM@hotmail.com 

-<>-
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Subtitles:  Terms & Concepts 
Special activities require specialized words, indeed here are introduced those related to what we'll

be talking about3, now on. If we are to communicate and understand each other, the preliminary and
fundamental requisite  and condition is  to  convene and agree clearly and unambiguously about  the
meaning of the specific terms we are going to use dealing with the elements of our activity. Here the
declared  purpose is  not  lexicographical  or  so—to that  purpose there  are  other  and more  qualified
sources—, but eminently practical, operative. 

<!> Please, do not proceed without paying the due attention to each and all the following terms, and to
the implied concepts. 

□

Terms 
Subtitle generic term referred to the main subject of this SE program. So generic, that we'll 

accurately avoid using it alone, without such necessary specification as:  Subtitle File,
Format, or Text. With, in particular, the Subtitle Text typically composed by just one 
or, at most, two Lines; not more4. 

<.><.> Here  Italics and initial Capital letter are used to signify, and recall, that we are deliberately
using a standard term with a precise meaning in a given technical context. 

Remark 
Throughout this Report all such terms as:  Subtitle Text, Record, List view, Table, Row, Column,

Record  Field  are usually  written  with  initial  capital  letter,  so  to  clearly  recall  their  conventional
meaning and role. Convention strictly observed at first, then gradually relaxed. 

□

File term here assumed as universally known to signify:  ordered set of Records, each 
structured into a precise set of Data items, or Elements, or Fields. Such as, as in the 
case of our specific interest (that is Subtitle files):  Initial time, End time, … and Text. 
Files are typically stored into a computer mass storage where they are identified by a 
Name, characterized by a Type extension, and a Path. 
 Subtitle Record may also be called Subtitle Fragment. Or, when here seen 
associated to the related Soundtrack segment:  Subtitle Unit. 

Record Field File as an ordered set of Records, Record as an ordered set of distinct Fields; this last 
concept particularly relevant dealing with Subtitle Records, composed, indeed, by 
distinct Fields, such as:  Start time, End time, Duration and Text. Text Field possibly, 
in its turn, comprising Markup Tags (such as:  </font>) and plain Lines of text. 

Timestamp encoded time information about an event. Thus a Subtitle record may be described as 

3 Cf.:  “El mundo era tan reciente, que muchas cosas carecían de nombre, y para mencionarlas había que señalarlas con el 
dedo.”, excerpt from “Cien años de soledad”, by G. G. Márquez (1969 ca.); worth reading in original. 

4 Nonetheless, here we feel no need for such further subtle definitions as “Closed Caption” (CC), or so. 
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composition of:  Timestamps and Text; usual Text, comprising, at most, two Lines. 

Remark 
Subtitle files may actually be of two distinct types:  

  Text format files – most popular specimen:  SubRip5 Text format, file extension“.srt”. With SE, it is 
the format of reference [cf. sct.:  Program Window \ Format, and cmd:  File > Save as…]. Rather common
are also the “.ttml” Timed Text Markup Language, “.dfxp” Distribution Format Exchange Profile, 
also “.ttml”-based, and the “.xml” formats. 

  Binary format files, that is Raster (Text) Image Files – most popular specimen:  Blu-Ray “Subtitle 
Bitmap”, file extension “.sup”. Bridge between these two formats is the technique of Optical 
Character Recognition. SE deals with this binary text kind of formats exclusively through File > 
Import and Export commands [see]. 

□

<!> Main purpose of this SE – Subtitle Edit program is, indeed, to edit, that is to read, play, test, modify
and write such Subtitle files. 

<!!> Note that  the other  multimedia Video/Audio files,  here relevant,  can be exclusively read and
played, that is NOT edited with SE. 

□

Table a convenient way of representing the a Subtitle file, in Row–Records and Column–
Fields. A given Column, on a given Row, identifies what is called a Cell, that is, in 
Record terms, a given Field of a given Record [see sct.:  Subtitle View and Video Work 
Area]. 

Media6 / Multimedia here typically to signify recorded Video (moving visual images) and Audio 
(sound, music, speech) sequences, flowing in the same Timeline. The same term can 
be used to signify either the h/w container, that is:  package, tape, disc; and also the 
contents, that is:  data file7. 
 The only Media here of practical interest are those manageable with a 
computer where the SE program can be installed and can operate. Media which SE is 
supposed to exclusively read and Play, that is certainly not to create nor modify, and 
typically associated with a distinct, autonomous Subtitle file, which is the main object
of the SE functionality. In case, as it is possible, a Multimedia already comprises also 
its own Subtitles, in that case SE cannot play any editing role on them. 

Virtual Screen form on the SE Window operating as an independent device where to play Video 
Media. 

5 SubRip is a GNU GPL free program to extract (“rip”) subtitles from various video to a text file. With its subtitle 
format's file extension “.srt”, widely supported. 

6 Actually a term used both as a singular and plural form. The original singular form “medium” in this context is ignored. 
7 Files of typical extensions:  “.mov”, “.mp4”. 
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Virtual Monitor perfectly analogous to “Screen”, but here conventionally reserved to the display of 
Soundtrack's Waveform, Timeline & related [see sct.:  Program Window & Context 
Menus]. Here we found rather convenient to introduce this conventional distinction 
between Screen and Monitor. 

Movie Movable (“moving”) Image, synonym to film. Sequence of images giving the illusion
of continuous movement. 

Still Image as the opposite of Movable Image. Single static image, with as “intermediate” 
condition that of a Sill Image inserted into a Movie. 

Audio Sound, that is all speech, music and noises, associated to a movie. 

Inscription writings possibly “burnt” onto some Movie sequence. Typically Titles, Names, 
Comments, such things; nothing to do with Subtitles as here intended. Also actual 
Subtitles can be “burnt” onto Movies, in that case SE has nothing to do with them, in 
the sense that they are out of its control. 

□

Segment contiguous portion of a linear sequence, as with a “line segment”; here typically:  
Soundtrack or Video Segment. 

Interval contiguous portion of time; here typically:  Timeline Interval. 

Timeline common timing scale for each and all Media in a given Multimedia; that is, typically: 
Video and Sound. Same time-reference is adopted by Subtitle too, with a difference:  
Video and Sound Timeline is out of SE control, whereas Subtitle timing is part of the 
Subtitle editing activity. 

Waveform is a way of representing a Soundtrack, with a horizontal time-scale (here:  Timeline) 
and a vertical sound volume indicative scale. It's the representation here in use. 

Soundtrack all sound, music, speech and noise, associated to a Video along the same Timeline. 

□
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Remark 
It is so frequent to talk about different Subtitle set in different conditions that we assumed here

convenient to propose the following specific terminology [N.B.:  the only somewhat “original” terms proposed
in this Report]. 

Unit a contiguous Timeline interval associated to a single Subtitle Record, conveniently 
represented “transparently” over the Waveform on the Soundtrack monitor – as in the 
following figure [cf. also:  Main Tasks and Soundtrack Work Area]. 

 It may be convenient to talk of Subtitle Unit, instead of Record or Fragment, when 
you'd rather consider it not exclusively in itself, but together with the associated 
Video and Audio segments, in the common time interval instead. 

<.> For practical reasons the single term “Subtitle”, when not otherwise specified, is here generally 
assumed to signify “Subtitle Record”, as a practical synonym of Unit. 

Void a continuous Timeline segment where no Subtitle Record is defined. As an extension 
of the above concept, it can also be considered as a Unit, a “Void Unit”. In this sense, 
a whole movie without Subtitles can be defined as “Void”. 

Gap void interval between successive Subtitle Records. 
<.> Do not undervalue the expressive role of “Gaps” between Subtitles:  
their extensions will limit the persistence of last Subtitle Text on the screen, and 
create a visual pause before the next one. 

Blank is defined “Blank” a Subtitle Record with an empty Text field. Of course “Void” and 
“Blank” are not the same thing, even though the result on the screen is the same. 

Silent is defined “Silent” a Subtitle Record containing Text not corresponding to any 
speech, or sound; that is, more sort of a caption than a Subtitle. To some extent a 
Silent Timeline interval is the inverse of a Void one, in the sense that:  
  Silent is a Subtitle text without corresponding Sound in that Unit, 
   whereas Void is an interval of Sound without corresponding Subtitle Text. 

-<>-
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Concepts 
Time “Time” is here operationally defined as that thing you measure with a watch, in 

Hours, Minutes, Seconds and decimal fractions of second:  hh:mm:ss.msec. More 
precisely here, at least for what Subtitle editing is concerned, we are dealing 
exclusively with Intervals of time, as defined by the Media considered, from which 
SE derives its time values; that is:  Timeline, Start, End and Duration.  
 “Absolute time”, “Event time” and “Real time”—whatever it means—is a 
Media's concern, only indirectly relevant for SE, through what is here convenient to 
call “Media time”, that is the proper Video and Audio Multimedia Time. 

 Preferred SE reference time is anyhow that of the Audio Media. The Video's and then 
Subtitle's time are conveniently derived from that primary reference, which is 
assumed as the “Media reference time”. There is a reason for that:  
 • Video-media is recorded and played as a discrete sequence of images, each of 
which could well be considered and viewed as a still image, that is independently 
from time. 
 • Audio in general, and speech in particular, is necessarily a time-sequence event, 
both whether considered as a real event or as a recorded and played (i.e. reproduced) 
one. There is not such thing as a meaningful “still”-sound, as a still-image can be. 
That is why the audio-timing is here considered as the unambiguous reference for 
Movie and Subtitles synchronization. 
 • Subtitles, meant to reflect voice and sounds, are laid upon images where they 
appear as still for an interval of time, so to be read by the viewer. It is with his reading
action that the viewer re-assigns a time sequence to the still text image. 

<.> All that here said also to unambiguously deal with such things and concepts as:  film frames, “.srt”
subtitle file type real timing, SMPTE timing (drop frame) and variable frame rate. 

□

Line A text may be subdivided into “lines”, separated by <CR> / <LF>, or <br /> if 
expressed in Markup terms. Subtitles texts can be subdivided into lines, usually not 
more than two. 
 Unfortunately, at present, SE makes a sad confusion between this neat and 
clear concept and such other completely different concepts, as:  Subtitle Record and 
Subtitle List view of row and columns. There are innumerable examples of that 
Babelic confusion [cf.:  Insert subtitle after this line…, Extend to line, Adjust durations for 
selected lines…], which is our firm opinion should be thoroughly and all fixed, without 
hesitation. 

-<>-
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What, How and Why 
What 

“SE –  Subtitle  Edit”  program—hereafter,  in  short,  “SE”—deals  with  Subtitle  files  as  an  added
functionality to  Video files.  SE comes handy to modify and tune Subtitle  files with respect to  the
associated Video, to create translated version of existing ones, and also to create them from scratch.
Purpose of this  Report is to describe in detail all such functionalities and that, as a rule, after having
tested them on a real case, on such computer configuration as here of reference [see:  Version Reference
above]8. 

Remark 
For what we know9 SE can operate exclusively on usual Subtitle and Video computer files, that is

not on Subtitles and Videos as, for instance, “frozen” on such media as DVDs. And that, apart from any
possible legal constraint. For this reason throughout this report we'll always talk not generically of
Subtitles and Videos, but always specifically of “Subtitle files” and “Video files”. 

□

How 
Anyhow the stated purpose doesn't come without the acceptance of some intended limits10, among

which there is the exclusion of some subjects here just hinted at, as considered off-scope and more
suited to be possibly described by dedicated papers [not here considered]. Examples:  

Edit > Multiple replace… a command comprising advanced Find & Replace editing tools and 
Regular Expression, here just cited [see]; 

Too specialized elements, such as the esoteric:  Proxy server settings, Token endpoint, FFmpeg [cf.]. 

Dedicated functionalities belonging to cultural environment and practice unknown to us [e.g:  
“Right-To-Left” writing, non-Latin Character Encoding], and whose availability is
a major SE quality not deserving to be spoiled with a shabby description. 

□

Inversely  some  other  SE features,  minor,  or  too  specialized,  or  highly  intuitive,  will  not  be  here
minutely described, but left to the user's creative understanding; as it would be highly impractical or
merely impossible do to otherwise11. Examples:  

Tool-icons, as in the Tool Bar [see], here assumed as not requiring any dedicated and 
detailed description. 

Command short-cuts, as Ctrl+Z, Ctrl+Y, in the Edit menu. 

8 Obviously leaving to each user the freedom of choosing any other compatible environment he wants, along with the 
consequent burden of taking care of the necessary and, hopefully, easily manageable specific differences. 

9 That is to say:  anyhow glad to be better informed. 
10 Then, of course, there certainly are also some un-intended, unintentional limits. Surely another story... 
11 In that accepting M. Talleyrand's advice:  “Surtout, pas trop de zèle”, with a fastidious doubt, though:  how much is 

“trop”? 
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Very common, similar or identical commands as:  Open, Close, Save; 
available in different menus and that will be described only once, if ever; 
then simply referred to, if ever. 

Detailed description of the “Alt” keystroke in getting, or not, such underlined keyboard shortcut 
characters:  

 as here shown in the Help menu. 

-<>-
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Why 
At the origin of our interest for Subtitles is the desire of really understanding the point of view of

others, as shown by original TV-News openly available on a public “Mediathek” (=media library), that
is, in the case of interest for us, in the German language. German is not among the two-three languages
we  understand,  therefore  the  availability  of  automatically  generated  subtitles  was  there  absolutely
precious. 

Alas, automatically generated subtitles are currently not that perfect, so that a program such as “SE”
was  really  welcome but,  again,  there  was  a  problem:   SE lacked  of  documentation,  therefore  we
adventured to test and document it for our personal use – and then, why not, on behalf of other would-
be users with similar aim as ours. Therefore, here we are, offering witness of our experience. That is
said also to “justify” in this Report the presence of so many Video & Subtitles examples dealing with
original German TV-News. 

<!> This is said also to delimit the range of our specific tests and experience about this (SE) program—
certainly a range not complete, nor particularly ample—so to accordingly warn the reader, and also to
encourage his possible contribution of other and different experiences of use. 

□

Who's Who, in our experience of use 
References and evaluations. 

SE – Subtitle Edit here, in particular, treated as a solution to Subtitle–Voice synchronization problems. 
 The appreciated subject of this whole Tech.Reference. 

MediathekView as “explorer” of German public TV Mediathek (media library, e.g.:  ARD-Mediathek), 
with related UT-Untertitel (subtitle) included, when available. 
 An excellent tool, technically reliable and stable12. 

AmberScript as a rather interesting Media voice-to-text automatic transcriber, of quality (text's, not 
subtitles') well above that of the current “on-the-fly” subtitle automatic generators, by
our experience. 
 An interesting starting point for creating brand new subtitles files out of 
Media where, for any reason, they are not satisfactory or simply not available. 

-<>-

12 But whose social environment (“Forum”) revealed unfriendly towards “foreigners”, with unsympathetic and arrogant 
attitude, sometimes even insulting. A sad human experience, alas. 
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Basic Tasks 
 S-PM 210400

“Technical  Reference”  and  “User  Guide”  are  standard  complementary  ways  of  conceiving  and
subdividing technical documentation, the first focused on tools, the second on results; both useful in
their own specific way. With this Tech.Report we dared to propose both such views about the Subtitle Edit
program, together, as considered equally relevant and useful13, assigning even precedence to the second
one, as here shown. 

BT0 – “Adjust”, Subtitle synchronization 
This task is at the origin of our interest for the process of Subtitle Editing, as our initial purpose

was to improve the quality,  and therefore the usefulness, of Subtitles generated automatically for a
German TV-News media, a feature we appreciated particularly as German is a language we do not
know very well. 

13 An unusual choice, about which it would be nice to know Mr. User's opinion. 
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Operating model 
The “Adjust” task here described is conducted operating on a specific issue of “Tagesschau ∙ Das

Erste”, a media of public domain, available on the ARD Mediathek web site14 [format:  .mp4], whose
issues can be downloaded directly15 or via the MediathekView program16, along with the associated
Subtitle files [format:  .srt and .ttml], generated automatically. 

The  specific  issue  here  considered  is  the  “Tagesschau  14_50  Uhr-0136664133”,  31.  Januar  2021,
available upon request as an “extras” to this  Tech.Report, along with the “fixed”—that is, adjusted—
Subtitle file as here generated, all that made available under the same “Creative Commons” conditions
as stated on the Copyright Page [see]. 

No change, no editing process will  be here performed on the original Subtitle text17,  even less,  of
course, on the original video and audio file. Our purpose here is simply that of improving the timing-
correspondence between the speech and the subtitles appearance on the screen, and also, whenever
possible, even with the lips movement of the speaker. That is, as usually called, the “sync”, originally
not always perfect, fairly understandable being the result of an almost instantaneous and automatic
process. 

□

Chronicle of a basic “Adjust” experience 
Main purpose of this section is to become familiar with related basic  SE tools & features. Operative
efficiency is not a first concern here, and is substantially left over as a subsequent goal, up to Mr. User. 

Actions 
A0) SE – Subtitle Edit program assumed as standard installed, up & running [see sct.:  Setup and General 

Management]. 

A1) Dedicate a directory to the Video “.mp4” and Subtitle “.srt” files, that is to the operating model as 
here considered [ref. above sct.], be it:  ...\SE-Lab. Plus, inside, a sub-directory where to store such 
useful items as:  back-up copies of all original files, included the other available Subtitle file of 
“.ttml” format, and then, prudentially, also back-up copy of the under-way edited file. 

A2) Run SE, in standard initial condition [that is, via:  File > New after a look at the:  Video Command Menu \ 
Requisite; and possibly:  Options > Settings… > Restore default settings > OK, so to ensure the overall 
standard initial conditions as here assumed]. 

A3) Choose tab “Adjust” on the Main Tasks area [ref.:  Main Tasks and Soundtrack Work Area]. 
Take care to adjust this area so that also the bottom-left “Video position” control is well in sight. 

14 [see:  https://www.ardmediathek.de ] 
15 [see:  https://www.tagesschau.de/download/podcast/ ] 
16 [see:  https://mediathekview.de ] 
17 Just the original subtitle file name has been altered with, indeed, an “Original–” prefix, and the here fixed one, with a 

“–fixed” suffix; caption terms also added to the respective silent Subtitle Record No. 3 [see on respective List view]. 

 – 14 –  

https://mediathekview.de/
https://www.tagesschau.de/download/podcast/
https://www.ardmediathek.de/


Subtitle Edit Basic Tasks  Technical Report

A4) File > Open the named original “.srt” Subtitle file, and then also the associated “.mp4” file. As a 
consequence you'll get the List view displaying an initial set of Subtitle Records, a still Video image
on the Virtual Screen and the Soundtrack in view as Waveform, on its dedicated Virtual Monitor. 

A5) Pay particular attention to “Video position” and “Start time” box values. 

A6) Ensure a Video position=0 and push the Play button, either on the Virtual Screen or on the Virtual 
Monitor:  you'll realize that even the first Subtitle text is displayed a short time before the related 
speech, inconvenience that then will get even worse. That's what we are here to fix. 

A7) So now the question is:  what is to be done so to “tune”, that is to better “synchronize” this first 
appearance of a Subtitle text with its corresponding speech? 
 We'll assume that, to begin with, the right tools to be used are precisely those available 
under the very “Adjust” tag, even though we know that there is a specialized and presumably 
powerful set of commands under the “Synchronization” main menu item [see]. 

A8) So, to the stated purpose, we re-Play the film starting from Video position=0, ready to “Pause” it 
as soon as we hear the first spoken words, so to take good note of:  
 • the “Video position” timing of such first spoken word (by the way:  06.04); 
 • the “Start time” of the Subtitle Record containing the words we've heard (by the way:  Record 
No. 2, Start time=02.120). Whereas the currently selected Subtitle Record on the List view is 
already the No. 3, well in advance with respect to the actual current speech. 

A9) Besides, we have noticed also the appearance on the screen of:  
 • an initial date/time [31. Januar 2021 / 14:53:ss] “printed” inscriptions that are certainly not 
subtitle text, in the sense that they are not originated by any Subtitle record; 
 • at first an initial Subtitle “blank” Record, that is one without any Text inside; 
 • and then also such a “silent” Record No. 3, certainly a Subtitle text (by the way:  “Herzlich 
willkommen...”), but not corresponding to any audible speech. Then ordinary “speech” Subtitles 
come. 

That is, here the initial Subtitle Records sequence:  
 – “printed” inscription 
# 1 Blank Record 
# 2 Speech – ordinary Subtitle Record 
# 3 Silent Record 
# 4 Speech 
… … 

Remark 
<.> Indeed, it is precisely because of the presence of such different elements as here seen—that is:

Subtitle items of different kind—that we are determined, in this  Tech.Report, to adopt a specific, non-
generic, non-ambiguous terminology [cf. sct.:  Subtitles:  Lexicon & Concepts]. 

□
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 Then it is also well worth taking good note of what is in display on the Soundtrack Monitor, 

 where you get visual “overlapped” correspondence between Waveform and Subtitle Records for 
each Subtitle Unit, as delimited by the transparent squared reference grid [see]. Note that the 
Subtitle Text will be here in sight only for a Monitor view scale at least 70%, and above. 

 Particularly relevant and worth “hands-on” testing actions here are:  
4horizontal sliding; 
4hand-dragging of a Subtitle Unit within its Gaps limits, on the Timeline scale (Ctrl+Z to undo); 
4right-click to select a Subtitle Unit (then red-colored); 
<.> other useful manual control actions, not even here cited, are left to the initiative of the 
adventurous Mr. User [please, be adventurous]. 

□

A9) All that considered, we decided to intervene first on the first spoken Record (that is the No. 4, 
“Heute im Studio: ...”, just after the “silent” one), and to synchronize it with the corresponding real 
speech making use of the powerful “Set start and offset the rest” Adjust button [see description at 
section:  Main Task:  Adjust]; this way:  
4select that Record on the List view and Go to sub position and pause 
4Play, ready to Pause as soon as heard the expected speech – which happened about at Video 
position:  16.600; 
4fine so:  that was where to “Set start and offset the rest”; 
4then a little more tuning, as it is nice to see Subtitle Text a little before the speech (never after); 
4this way:  manually dragging the Unit a bit left; again Set start and offset the rest, and checking 
the result on Video screen, possibly at “full screen”. This way we found that Start time at position 
15.7 sec was a better choice.- 

A10) Preceding Record (# 3), being “silent”, that is not linked to any speech, is freely movable by 
hand within the large room now available within preceding and following spoken Records. So 
that, the very first spoken Record, that is the No. 2, was easy to be adjusted by hand, and via a 
dedicated “Set start time”; that is, obviously, without altering all subsequent Records of the film. 
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 Doing that we “discovered” rather convenient to jump from one Unit to another clicking 
the desired Record on the List view. 

Remark 

<.> Possible timing conflicts are conveniently signaled on the List view color-coding the offending
field values (Ctrl+Z to undo). 

A11) Resulting Sync-tuning effects on a specific Record can be evaluated via (^) Play selection context 
command [shortcut:  F5], aimed at focusing your attention precisely at the currently selected 
Subtitle Record Unit [see:  Soundtrack Context Menu]. 

A11) A nice File > Save, and we are ready give a look at, and take care of, the remaining part of this 
same film in a next tuning session. 
 Well, almost, in the sense that we'll leave this task to the adventurous Mr. User, hoping to
get news from him about his experience [Thanks!]. 

A12) So far we have improved the speech–Subtitle text synchronization substantially evaluating and 
tuning numeric time values. Essentially:  Start time, End time, Duration. Well, there is another 
way to do the job; an “analogical” way, rather convenient and worth learning. It is substantially 
based upon the context command (^) Play selection, this way:  
4select the desired Subtitle record on the List view or, alternatively, clicking directly on its Unit
in the Waveform monitor, whether in sight; 
4Adjust \ Go to sub position and pause to set the “vertical green-line” Position marker; 
4(^) Play selection [shortcut:  F5]; 
4just move/extend/reduce the Record Unit interval acting directly on the virtual Monitor; 
4(^) Play selection again, to verify results; 
4go to next Subtitle Unit; also (^) Split and (^) Delete context commands may come handy [see]; 
4from time to time Play and evaluate all movie from the beginning up to the last adjusted 
Record. As simple as that.- 

Compare the two here contributed Subtitle files:  the original one vs. the “adjusted”, to appreciate the
difference. 

□

Automatic Subtitles 

<?> At this point a naïve question:  why on earth should Subtitles be fixed, shouldn't they be
created well at first, when they are created? There are many reasons for that, here we'd consider just
this one:  
 <!> It is convenient, if not necessary, to produce some Subtitles automatically, even though such
production  is  not,  and  probably  will  never  be,  absolutely  “perfect”  (←anyhow,  a  rather  slippery
concept in itself...). And that is particularly true with such thing as TV-news, as here considered. 

-<>-
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BT1 – “Create” a Subtitle file, from scratch 
Starting point is here a Video file of charming beauty, rich in dialog and comments, in a regional

language, originally with no subtitles18. 

Operating model 
Now the aim is to provide such Video with Subtitles, in multi-lingual versions. Copy both of this

Video and the resulting Subtitle files as here created are available upon request as “extras” to this
Tech.Report, under the same “Creative Commons” license as declared on the Copyright Page of this very
Report [see]. Hereafter, title and description. 

□

The village is reborn 
“On the Carnic Alps, in the province of Udine, there is a corner of Friuli-Venezia Giulia that is still 
authentic:  the Aupa valley, with its crown of human settlements rich in peasant history. Unfortunately 
many of these villages are now sparsely inhabited, sometimes abandoned. But there are some 
exceptions, as in the case of the village of Dordolla, located at 630 meters above sea level it is the most
lively and active center of the valley:  instead of emptying itself, it attracts people, residents or visitors.
Especially in summer, when cultural events and initiatives flourish.” 
[St 2020/21 28 min] A documentary by Aldo Pavan and Marisa Bortoletto.- 

□

18 Courtesy of the owner (and the Authors), from:  https://www.raiplay.it/video/2021/03/Il-borgo-rinasce---
29032021-aba9c261-74cb-4e80-b6a7-c95fa23a3a91.html?wt_mc=2.www.wzp.raiplay 
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Chronicle of a basic “Create” experience 
Main purpose of this section is to become familiar with basic SE-“Create” tools & features. Operative
efficiency is here not a first concern, being substantially left over as a subsequent goal up to Mr. User. 

Viewpoint 
Subtitle Texts are to be edited according to basic style rules primarily regarding the max. number

of lines and of char.s per line. Most common of such rules are by:  
Netflix max 2 lines, 42 char.s per line; 
BBC max 2 lines, 34 char.s per line. 

SE doesn't recall explicitly such rules, they are considered instead as  Options > Settings… : General,
where you are offered such default values:  Single line max. length=43 / Max number of lines=2 

<~> It is our opinion that, at least during a “Create” session, it would be nice to be recalled about such
relevant figures on the bottom Status Bar. 

□

Actions 
A0) Former “BT0” section [see] is here assumed well known, and the implied expertise acquired. 

A1) First action here is the transcription of the whole original movie “script”—here intended as 
speech, that is all audible comments and dialog—on a standard text file, ready to become a 
comprehensive Subtitle file. Before endeavoring into a painstaking manual transcription process 
we took the opportunity for investigating how mature are the currently available audio and video-
to-text transcription services, such as that one offered for instance by Amberscript19. Also a good 
opportunity to evaluate and compare such experience of ours among the community of SE users. 

A2) Select the “Create” tab, and click on the Virtual Monitor to load the desired “Dordolla 1280.mov” 
video file. 

19 Ref.:  Amberscript B.V., Keizersgracht 668b, 1017 ET Amsterdam; https://www.amberscript.com 
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A3) An initial “Insert new subtitle at video pos”, and then the task can begin, with subsequent “Insert” 
actions at the next desired Video positions. 

Here in show a typical operative situation after an initial “Insert new subtitle at video pos” 
command, clear enough not to require any further explanations, but for:  

Auto (blinking) before the Duration caption, to say that it will be automatically evaluated 
according to the actually entered Text, when “played” at the given speed of 15.29 Chars/sec 
(indeed:  45 chars / 15.29 chars/sec = 2.94 sec). 

Auto br automatic“break” (<br />) of the entered Text into lines (by the way, default Max.number of 
lines = 2). 

45 red-colored line length, to say it is beyond the default limit value of 43, as with Options > 
Settings... : General \ Single line max. length [see]. 

45, 47, 46 slightly different line length values to say, respectively:  trailing blank ignored, next char. 
position (on the 1st line of Text) and total length, trailing space included. 

□

A2) Typical sequence of actions with each new Subtitle Unit is:  
4Insertion of desired Text, possibly with Line-break and formatting [see:  (^) On:  Text Edit Form]; 
4positioning of the right-margin of the Subtitle Unit to make enough room for the Text; 
4a look at the List view if any error condition. Typically:  unsuited line-breaks, timing-conflicts.- 

Remark 
Line-break and formatting implies the automatic insertions of such Markup Tags into the Subtitle

Text:  <br />,  and  <font color="#FFFFFF"> </font> pairs;  tags of which Mr. User is not going to be
directly bothered about. 

Viewpoint 
Consider that it is nice to have Subtitles appearing on the screen just a little earlier, and then lasting

a bit longer then the corresponding speech. That means also that the extension of the pause between
Subtitle Units—that is:  Subtitle Gaps—plays a rather relevant expressive role. 
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Then a slow “Play rate (speed)” [see sct.:  Soundtrack Controls and Actions] may then come handy to fine-
tune both timing and text-speech correspondence20. 

□

A3) But then, even for a relatively short film (28 min.), this way of inserting one Subscript Unit at a 
time, reveled rather painstakingly tedious and slow. Therefore we endeavored to find out a 
quicker SE tool, given the fact that, via Amberscript [see], we got the entire film's script 
transcribed also into an “.srt” Subtitle file type. 
 Actually a Subtitle file really poorly subdivided into almost “random” Records (by the 
way, the reason why we didn't use it first). Anyway, we copy-pasted the desired amount of 
Records (actually, records # 46   206, that is excluding those already inserted one-by-one) into a 
“.txt” file type, so that we could then utilize the presumably powerful context command:  
(^) Insert subtitle after this line… [see]. 

A4) What we got was a nice “raw” complete Subtitle file, unusable as such, but good enough to be 
corrected individually (a typical “Random Edit and Sync” activity), making good use of the 
expertise acquired with the preceding “Adjust” Basic Task [see]. That, plus such other Merge / 
Split / Delete context commands [see sct.:  Soundtrack Context Menu], we could complete 
satisfactorily also this second “Create” Basic Task”21. 

A5) <!> Here we found also particularly handy, even precious, the (^) Play selection context command 
[shortcut:  F5], to focus attention on each specific Subtitle Unit. 

-<>-

20 <.> This tiny set of hints is here the maximum we dare to say about the art of subtitling. 
21 Result, as said, also available upon request as “extras” to this Tech.Report. 
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BT2 – “Translate” a Subtitle file, multi-lingual 
Let's assume to have “Created” a nice Subtitle file, and well “Adjusted” it to the related video-

audio media file [see preceding sct.s], now the task is that of deriving from it a pair of other Subtitle files 
translated into different languages, say:  German and English. Let's see hereafter how it can be done. 

Here is the dedicated Translate tag, take care to adjust the frame so to have all the task area well in sight.
Besides, there is an interesting Auto-translate > Auto-translate… main menu command on which to rely
upon [see]. Let's consider what can be done to the stated purpose. 

Viewpoint 
As  said,  Translate bottom controls  can  possibly  go  off-frame,  and  that  shouldn't  with  a  more

accurate automatic resizing of this area22. 
□

Actions 
A1) The Subtitle file here considered:  …\Dordolla 1280.srt, name shown at left on the Status Bar [see], 

isn't that short, as it contains more than 300 Subtitle Records. Therefore we decided to process the
lot trying the promising Auto-translate command [see on:  Main Command Menu], the following way.

 4 File > Open : …\Dordolla 1280.srt 

 4 Auto-translate > Auto-translate… : Service:  Google Translate V1 API \ From:  Italian \ To:  German \ 
Line merge:  No merging <– instead of the default condition Merge max two lines, for two Reasons:  

 R1) We are doubtful about the real meaning and role of the “Line merge” feature, being, alas, the 
SE term “line” rather ambiguous [cf. sct.:  Subtitles:  Lexicon & Concepts]; 

 R2) It is our intention to deal with the same number of Subtitle Units—i.e. Subtitle Records—for

22 <~> Not an infrequent SE inconvenience, alas. 
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all possibly translated Subtitle files. Indeed, if the case, equalizing the number inserting “dummy”
Blank Records. Therefore we'd rather avoid any such action as an automatic—that is uncontrolled
—merging of lines, whatever it means. <~> Anyhow, we'll certainly investigate about this 
“merging” feature too. 

 4 Then:  Translate, ignoring the rather cryptic consequent message—something about “API key”—
investigation postponed, as about the above cited “V1 API”. As a result we got this mysterious 
message:  

 Message that we interpreted this way:  the “Auto-translate” feature relies upon an active Internet 
connection, a prerequisite that we'd consider fair not fail to signal in advance where appropriate. 

4 Indeed, Internet connection granted, we got and OK–saved a nice automated translation, then 
shown on the SE Work Area this way:

 that is, with some not negligible flaws hopefully to be fixed soon [see next sct.]. 

□

To be fixed:  

 <~> “Original text” caption misplaced on the Text box; and the bottom info line miss-printed. 
Condition then not repeated when re-entering the same job. 
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 <~> Then, at exit, you will be anyhow asked:  

 

 even with no changes whatsoever on the original Subtitle. 

□

 Anyhow, an overall positive result deserving three relevant Remarks:  

 R1) Both original and translated Subtitle files will now be in display on the SE Work Area, with 
the main focus on the translated one. 
<!> As a consequence, the before mentioned preference for en equal number of records in both 
files, results particularly valid, otherwise comparison would result really odd. 

 R2) Some translated Subtitle records result error-marked, such as:  

 presumably because of different and conflicting word / text lengths. To fix them the “Adjust” 
experience will come handy [see sct.:  BT0 – “Adjust”]. 

  R3) Translated Subtitle file will be named after the original one, suffixed with such a language 
code as “.de”; with these consequent “Open” conventions:  

 • Original Subtitle file can be opened singularly, as before; 

 • Opening of the translated file implies also that of the original one too, if present in the same 
directory; otherwise it can be opened singularly. That is, obviously functional to making a 
comparison among the two, presumably operating under the “Translate” tag; an operating way that
it is not our goal to explore here in detail. 

 • As a rule, automatic translation requires qualified tuning of the resulting text. Activity that, in 
our experience, has been conveniently carried on apart from SE, and almost exclusively as a 
linguistic task. 

□
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Remark 
<~> During this basic tasks experience we have noticed some examples of poor auto-positioning

of elements within the frames. Here some examples. 
□

Here the overlapping on the central pair of “2,24” figures, those without a leading caption. 
□

Here the right off-flow of the “Chars/se” caption, and figure. In this case we've noticed that a sequence
of Maximize / Restore window may fix the trouble. 

-<>-

The Art of Subtitle Editing 
Subtitle editing, more than a craft, is clearly an Art, an art as that of writing “opera librettos”. That

is  evident  even  after  the  elementary  experience  gained  with  such  basic  “Adjust”,  “Create”  and
“Translate” tasks as here described. 

An art for which the timing—that is:  start, duration, pause—has a particularly relevant expressive role,
besides that of the literal meaning, as, indeed, with the opera librettos. Here some relevant aspects to be
considered:  

Reading time: the user must have the time to read it, and timing of reading is generally not the same
as the timing of speech; 

About start time: not too much in advance with respect the actual speech, just a little bit, at most; 

About duration: it may remain longer in view then the actual speech, so, for instance, to give time to 
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read it, provided there is no danger of overlapping with the next speech; 

Pause: it's fundamental, so to re-gain fresh attention for what follows next; 

Punctuation: just essential, otherwise it's distracting; 

Translation: a timing challenge, given the fact that different languages may well have completely 
different word lengths. 

<.> Indeed an art, about which all that can be fairly here offered are simply some technical tools, with
the rest left up to you. 

□

Conclusion 
To  this  basic  “User  Guide”–style  section,  a  much  more  complete  and  detailed  “Technical

Reference”–style treatment follows. Two prospective conclusions may be drown:  

✔ Combined hands-on experience and detailed SE knowledge are both crucially user-beneficial; 

✔ Fair feed-back from experienced users is crucially beneficial for future Tech.Report development
and issues.- 

-<>-
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Program Window & Context Menus 
S-PM 210200

On the  SE Program Window it  is  convenient  to  distinguish  and describe  separately the  following
components:  Title Bar, Main Menu Bar, Tool Bar, Main Work Area, Status Bar. Description referred
exclusively to the standard SE initial setup, not here considering the possible different choices the user
is  entitled  to  make  through  such  commands  as:   Video >  Show/hide  waveform and  video,  or
Video > Un-dock and Re-dock video controls [see]. 

Remark 
Appearance of SE Program Window on the screen will depend also upon the system Start > Settings

> System > Display : Scale and Layout, where you may:  “Change the size of text, apps and other items” [see]. 
□

SE Program Window, “exploded” 
Title Bar 

Standard Title Bar positioned, as usual, at the top of the program's window, with, at left, the standard
Icon Menu23 and, at right, the Minimize, Maximize and Close buttons. And also showing the currently
opened  Subtitle's  file  name,  if  any—otherwise:   “Untitled”—,  followed  by  the  “Subtitle  Edit”  full
program’s name and version in use. 

□

Main Menu Bar 

Main menu bar, functionally described in detail hereafter, on the dedicated section [see]. 
□

23 A menu here not described, as usual for all such standard features assumed as well known. Just a remark:  please notice 
the presence of a dimmed-disabled “Restore” command, a rather standard and useful convention that we’d appreciate 
would be commonly adopted by the SE program too, as we’ll have some occasion to suggest hereafter. 
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Tool Bar 
 

 

Standard  SE Tool Bar, composed of shortcut icons for some frequently used commands hinted at by
such tooltips as those here shown, plus a couple of  Drop-down lists—Format and  Encoding—worth
some explanation. 

Format More precisely:  Subtitle file Format. A drop-down list where to choose a Subtitle file
format possibly required to File > Open it, or to File > Save, Save as… it with a format 
possibly different from the automatic SE-default value, in which case the Save 
commands [see] operate also as a conversion tool24. As a rule, the automatic default 
format is that of the opened file, auto-detected. On top of this list there is the most 
popular SubRip “.srt” type. 

<~> Note the curious presence of some rather odd choices as the many “Unknown nn 
(.txt)”, and the absence of the rather common Subtitle file format “*.ttml”25. 

Remark 
Even if not in this list, a “.ttml” Subtitle file can be Open-ed, recognized as a “Timed Text 1.0 (.xml)”

format. Then it can be Save-d as such, or converted, e.g. as “.srt”, with the Save as… command [see]. 
□

24 <.> File conversions, in general, are required when, for some reason, no unique standard format is universally accepted. 
And, apparently, that's currently the case with Subtitle files. 

25 By the way, the only one we know besides the popular “.srt”. 
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Encoding More precisely:  Character Encoding, that is the encoding of characters for Subtitle 
texts. May come useful with File > Import [see] for conversion purposes. Rather 
relevant feature with Subtitles possibly written in any of the world languages26. 

□

Main Work Area 
 

 

Main SE Work Area, internally subdivided into two dedicated areas, here conventionally referred to as 
Video and Soundtrack—more precisely:  Subtitle View and Video (above), and Main Tasks and Soundtrack 
(below)—work areas, on which specific Main Menu and context commands operate. 

26 Anyhow, a feature in which we have no direct experience, being substantially confined within two-three west European 
languages. 
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Areas contained within rectangular frames which can be conveniently resized by means of such usual 

controls as:  , and that will be described in full detail hereafter, along with the related context 
commands [see]. 

□

Status Bar 
And now, the bottom Status Bar, where to display such information as:  

 

Here a double click27, and you'll get such a “Status log”:  

-<>-

27 <.> Mouse-related action, symbolically represented throughout this Report with a:  (^) 
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Subtitle View and Video Work Area 
S-PM 210200

Here is where to watch Subtitle and Video files, combined. An area rich in controls, most intuitive
enough not to require any further description, and rich in powerful context menu worth full description.

Structured records of Subtitle file are here in display as rows of a table, conveniently organized in
columns corresponding to distinct record-fields, with then, at right, a handy screen for the related Video
file. A right-click on that screen is equivalent to  Video > Open video file… command [see].  See then
hereafter described all the Context Menus available on this area. 

□

Subtitle View Context Menus 
SE is  rich in  context  menus,  most  of  them offered precisely where they are more useful,  and not
available anywhere else, plus some othrers that can be found also elsewhere, as within the ordinary
Tool Bar, and here duplicated just for convenience. 

□

(^) On:  Title Row 
A right click [symbol:  (^)] on the Title row of the Subtitle table, and you can modify the display of

record's field-columns. 

Remark 
Notice that whilst such Subtitle timing parameters as Start, End and Duration time are under direct

SE operator's control, Char/sec and Words/min are not, in the sense that they are evaluated as a ratio
between the number of characters, or words, and the time Duration of their display on the screen.  
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More precisely,  considering actually readable characters only,  that  is  with the exclusion of HTML
markup tags, e.g. encoding Italic, Bold and Underline characters; and possibly the exclusion of spaces
according to Options > Settings… : General \ Chars/sec (CPS) includes spaces [see]. 

<!> Meaning—and therefore relevance—of the Char/sec and Words/min parameters is that they offer
an indication about the reading speed required to the film viewer to effectively utilize the presence of
Subtitles, knowing that an average user hardly can read more than three words per sec., that is more
than about twenty char.s per second. 

□

(^) On:  List View (empty) 
A right click on an empty row, and you get inserted a new Subtitle record—with no text, just

default time parameters—, 

or you can Go to source view, as hereafter shown. 
□

(^) On:  Source View 
The same Subtitle file can be seen in a Text-editor “source view”, that is as a continuous sequence

of structured records, instead of as in a “list view” table of row and columns. 

A source  view where,  with  a  right  click,  you'll  get  a  Subtitle  edit  context  menu  as  here  shown,
including a command for back to Go to list view. Other commands here deserving description are:  

Insert Unicode symbol as with Edit > Insert Unicode symbol [see] 
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Insert Unicode control characters designed for dealing with “Right-To-Left” languages, as Arabic and 
Hebrew [all we can here say, being that a cultural environment unknown to us] 

Warning 
Consider that in this  Source view you may easily “corrupt” the structure of a Subtitle record,

typically inserting text characters into time-parameter fields. 

In that case, when trying to go back to the List view, you'll be informed about the inconvenience with
such diagnostic message. 

□

(^) On:  List View (non-empty Row) 

 

Remark 
Notice  the  color-coding  of  the  selected  record.  Would,  as  possible,  any error  condition  arise,

typically because of timing-conflicts, the List view will show it with a specific color-coding on the
offending values [see:  Options > Settings... : Syntax coloring]. 
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Command List 
Delete Insert before Insert after Insert subtitle after this line… 
Copy as text to clipboard Column Toggle bookmarks - add comment 
Go to source view Split Merge with line before 
Merge with line after Extend to line before Extend to line after 
Remove formatting Bold Italic Underline 
Color… Font name… Alignment ♪ Typewriter effect… 
Karaoke effect… Show selected lines earlier/later… 
Translate selected lines… Adjust durations for selected lines… 
Fix common errors in selected lines… Change casing for selected lines… 
 

□

Viewpoint 
As you see, context menu associated to a “non-empty” List View is considerably ampler than that

associated to an “empty” List View [cf.], in coherence with, indeed, the different operating context. 

Fact is that we oddly have noticed a similar “dynamic” change of menu length also with non-context
SE-Main  menu  [e.g.  see:   first  Viewpoint at  sct.  File  Command  Menu]  where,  and  for  good  reasons,
commands possibly inapplicable in a given circumstance should, as a standard rule followed by all
programs we know, merely become dimmed-disabled but still kept present where they are located, so to
keep non-context menu unchanged in composition and length. 
<!> That is to say that we'd be strongly in favor of this standard way of doing things with SE too. 

□

(^) Delete 
Just delete all Record-rows currently selected on the Subtitle Table, in List view. 

As usual, a Ctrl+Z to undo. 
□

(^) Insert before 
(^) Insert after 

Insert a new blank record before/after the currently selected one. 

Beware:  Timing-overflow condition not detected [cf. next:  (^) Insert subtitle after this line…]. 
□

(^) Insert subtitle after this line… 
Insert all Records of a given Subtitle file after the currently selected Record on the List view.  

Possible error condition may arise, as List view will show. 

Insert Overflow 
<~> Be  aware  that  current  SE program will  accept  all  kind  of  new Subtitle  Record  “Insert”
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commands, without checking whether there is still time-room left, or not. As a result new Records may
be “added” after the actual End-Of-Film, that is in time-overflow condition, that is  nowhere, without
Mr. User being informed of the incongruity. 

Viewpoint 
<~> Of course this command refers to “Records”, not “Lines”. Lines are elements of a Text field,

whereas it is Records which are the elements of a Subtitle file [see sct.:  Subtitles:  Terms & Concepts]. 
□

(^) Copy as text to clipboard 
Copy the whole contents—that is, all fields, not only the text—of the currently selected Records

into the system clipboard, ready to be possibly pasted somewhere else, that is possibly via:  (^) Column >
Paste from clipboard… [see]. 

□

(^) Column 
Activate the following context  sub-menu operating on the currently selected set  of contiguous

Subtitle records, as hereafter described in detail. 

Viewpoint 

<~> In  spite  of  the  name,  this  context  sub-menu  is  evidently  not  referred  to  any  particular
“Column”, but to the entire Subtitle Records here displayed as Table Rows, instead. 

□

Command List 
Delete text Delete text and shift cells up Insert empty text and shift cells down 
Insert text from subtitle… Import text and shift cells down Paste from clipboard… 
Text up Text down 
 □

(^) Column > Delete text 
Delete the Subtitle text contained into the selected contiguous Records. All other Record Fields

remain unaltered (Ctrl-Z to undo). 
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□

(^) Column > Delete text and shift cells up 
Delete the Subtitle text contained into the selected contiguous Records, and replace it by shifting 

up the text Fields of the subsequent Records. All other Record Fields remain unaltered. 
□

(^) Column > Insert empty text and shift cells down 
Shift down Text Fields orderly out from the selected Records, leaving the original cells empty. 

Bottom Text Field are lost, all other Record Fields unaltered. 
□

(^) Column > Insert text from subtitle… 
Substitute orderly, from the currently selected Record on, all text Fields with those found into the 

Subtitle file to be opened. No new Record will be created, no other Record Field altered. 
□

(^) Column > Import text and shift cells down 
Interesting,  innovative,  and  powerful  tool  that  we'll  here  describe  by  means  of  a  particularly

relevant  example  of  use,  so  to  focus  more  on  its  the  general  functionality  rather  than  on precise
operating details. That also because, as we have been informed, this command is currently:  

 <Under revision>28 – Report left AsIs 

To begin with, consider that currently are available many ways to automatically transcribe into text
files  the  speeches  as  recorded into  audio-video multimedia.  A functionality useful  in  general,  and
particularly in  case of conferences,  meetings or lessons.  Well,  this  SE-tool  can happily be used to
convert  such a text-transcription file into a Subtitle file to be added to the related media,  as we'll
hereafter describe29 [as you see, the future is already here]. 

Steps 
4 First action is the creation of a dummy Subtitle file containing just one Record. Be it:  

 4 On that dummy new Subtitle, open the named multimedia file, and give it a look so to notice its 
duration [in our test-case:  06:36 mm:ss]. 

28 <~> And also “Under refinement”, we'd dare to suggest, starting from the command's caption, with its missing trailing 
ellipsis “…”, and the misleading term “Import”, at least that to be corrected with a more precise “Replace”. 

29 In our hands-on test the speech-to-file transcription was obtained using the services as available online by Amber Script, 
www.amberscript.com [see]; and the test multimedia file was a short TV-News as available on the public media library
https://www.tagesschau.de/download/podcast/ [see]. 
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4 Then, such a first “Import plain text” call, so to get a significant “Preview” of the final result.

Notice, in particular:  

• “Import options” area, where to set the criteria for splitting the transcribed text into Subtitle 
records, here deliberately left to the default condition. 

• “Generate time codes” and “Duration / Auto” controls, currently inoperative:  
<~> a known bug, to be fixed soon. 

• Record No. “#” [here:  109] and “End time” [cf.:  test media file full duration] of the last Subtitle 
record, useful data for the next operative step; that will be:  

 4  Creation of a suited set of dummy Subtitle records to be added after the first. A set required by this
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tool aimed at operating exclusively on existing Records, that is, without creating any new one30. 

 4 The desired set of dummy Records [here:  109] can be easily and quickly created duplicating, via 
Copy [Ctrl+C] and then repeatedly Paste [Ctrl+V kept pressed], a suited model-Record with such a 
Duration [in our case ca.:  3,4 sec] to cover the entire media duration [in our case ca.:  06:36 mm:ss]. 

 4 Now you are ready to call again “Import plain text” followed by “OK”, so to get all the dummy 
Records filled with the “real” Subtitle text. As simple as that. 

4 Then “(^) Adjust durations for selected lines…” and “(^) Fix common errors in selected lines…” may do. 
But certainly then only a patient “manual” revision and editing (a typical “Random Edit and Sync” 
activity) will complete the job. 

Controls 
Import plain text rather appropriate title, with the keyword “plain” to imply the process of conversion, 

indeed, from plain text to formatted Subtitle records. 

Open text files…  two possible ways:  one unique text file containing the whole lot; or... 
Multiple files or distinct files, each one assumed containing just one Subtitle record. 

Preview a consequent display table offering an immediate idea of the result. 

Import options assumed as self-explanatory, and anyhow easy to test. 

□

Viewpoint 
In  conclusion,  our  suspect  is  that  the  obscure/inappropriate  command  caption  and  possible

execution inaccuracy are not the consequence of coding errors but rather symptoms of some unripe
basic design, with consequent ambiguity and contradiction, to be fixed first. 

□

(^) Column > Paste from clipboard… 
Paste Subtitle record fields starting from the currently selected record, and according to the options

chosen in this control box; particularly those about Overwrite or Shift mode. 

30 <~> That's why here we consider improper the term “Import”, being this a typical action of text “Replace”. 
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A command well suited to paste Subtitle records copied via (^) Copy as text to clipboard [see]. 
□

(^) Column > Text up 
(^) Column > Text down 

Swap Text field (only) between consecutive Records. 

-<>-
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(^) Toggle bookmarks - add comment 
Enter/cancel a “bookmark”-label31 onto the selected Record. 

The Record will result accordingly flagged. 
□

(^) Go to source view 
To switch from List to Source view (F2 to toggle). Context menu will change accordingly [cf. sct.s:

(^) On:  Source View and (^) On:  List View]. 

□

(^) Split 
(^) Merge with line before 
(^) Merge with line after 

Split/merge  currently  selected  single  Subtitle  Record  [hint:   hands-on  to  test  operative  details].  
<.> When more than one Row selected, these three commands change into the following two [see next]. 

Viewpoint 
Obviously not referred to “Lines”, but to List view Rows, that is Subtitle Records, instead. 

□

(^) Merge selected lines 
(^) Merge selected lines as dialog 

“as dialog” is to signify:  with leading “-” hyphens [hint:  hands-on to test operative details]. 
□

31 In itself stored along with the related Subtitle file, into such file type:  “*.SE.bookmarks”. 
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(^) Extend to line before 
(^) Extend to line after 

Extend the current Subtitle Record time duration up to the Record before / after. Involved Records
remain distinct. No such Extend action takes place before the first / after the last Record. 

Remark 
We have noticed that this extend action reduces the Gap between Records to about 24 msec [cf.:

Options > Settings… : General \ Min gap between subtitles]. A value that may be further reduced by hand to
the point that, in case of a (^) Play selection action, current selection will be transferred to the successive
Record, up to a larger Gap is encountered. 

Viewpoint 
<~> In this command it is particularly evident the necessity of a sound and unambiguous definition

of the terms in use, as proposed with section “Subtitles:  Terms & Concepts” [<!> see]. Obviously here the
term “line” is absolutely inappropriate, as it should concern Texts, not certainly Records. 

□

(^) Remove formatting 
(^) Bold 
(^) Italic 
(^) Underline 
(^) Color… 
(^) Font name… 
(^) Alignment 

 

Set / remove Subtitle text formatting as displayed on the screen, for all selected Subtitle Records. 
□

(^) ♪ 
Insert a “♪” symbol at the beginning and at the end of each single text line of each Subtitle Record

selected, to signify the text is assumed to be sung, instead of spoken [cf.:  Edit > Insert Unicode symbol]. 
□
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(^) Typewriter effect… 

Feature to make the Subtitle text appearing on the screen as typed one character after the other. 

Warning 
The Subtitle timing will be, comprehensibly, deranged. 

□

(^) Karaoke effect… 

Viewpoint 
Gene Kelly32 would have appreciated it. 

□

32 Gene Kelly, a guy who enjoyed “Singin' in the Rain” and being “An American in Paris” (1950s). 

 – 42 –  



Subtitle Edit Program Window & Context Menus  Technical Report

(^) Show selected lines earlier/later… 

Tune the timing of Subtitle Text appearance on the screen, according to the set-up on this control form,
assumed  self-explanatory.  Analogous  to  (^)  Adjust  durations  for  selected  lines… and  Tools >  Adjust
durations…commands [cf.]. 

□

(^) Translate selected lines… 

Precisely the same feature as that of  Auto-translate >  Auto-translate… command [see], but aimed at the
selected Subtitle records33, instead of the whole Subtitle file. 

Refer to the cited Auto-translate > Auto-translate… command for complete description of this feature too. 
□

33 Of course Records, or equivalently Rows, not certainly lines, as here said… [cf.:  Subtitles:  Terms & Concepts]. 
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(^) Adjust durations for selected lines… 

Self-explanatory feature about Subtitle timing34. 
□

(^) Fix common errors in selected lines… 

Self-explanatory command and control form, with specific items left to the user's curiosity & initiative. 
□

34 <.> Rather powerful, worth thorough testing as specific synchronization tool. 
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(^) Change casing for selected lines… 
Set the text casing on currently selected Records as decided in this control form, markup tags

excluded [cf.:  Tools > Change casing…]. 

A control form self-explanatory enough not to require any further description, but for:  

(via Dictionaries\names.xml) same “Names” dictionary as described at command Tools > Change casing… 
[see] 

Viewpoint 
This command is obviously referred to Subtitle Records, i.e. List view's Table rows, not certainly

“lines”, as the caption imprecisely says [see sct.:  Subtitles:  Lexicon & Concepts]. 

-<>-
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(^) On:  Text Edit Form 

Command List 
Cut Copy Paste Delete Split line at cursor position 
Select all Remove all formatting Bold Italic Underline Color… 
Font name… Insert Unicode symbol Insert Unicode control characters 
 □

(^) Cut / Copy / Paste / Delete [assumed as well known] 
(^) Split line at cursor position [cf.:  (^) On:  List View (non-empty Row)] 
(^) Select all [assumed as known] 
(^) Remove all formatting / Bold / Italic / Underline / Color… / Font name… 

[cf.:  (^) On:  List View (non-empty Row)] 
(^) Insert Unicode symbol / Insert Unicode control characters 

[cf.:  (^) On:  Source View] 

-<>-
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Main Tasks and Soundtrack Work Area 
S-PM 210200

Here is the SE-cockpit where, as the Tab-labels tell, to Translate, Create, Adjust a Subtitle file; all 
combined with the above part of the main work area, that is the Subtitle View and Video Work Area [see]. 

Two distinct sub-areas: 

 At right, a virtual monitor visualizing the soundtrack along with the associated Subtitle text and
some related numeric data, and also equipped with touch-screen and control capabilities; as
hereafter described in detail. 

 At left, three overlapped Tab-control pages, equipped with dedicated task-controls and context
menus; as hereafter described in detail. 

Warning 
Resizing the SE-Window to its minimum size will hide the bottom part of this left sub-area. 

□
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Soundtrack Virtual Monitor 
Here a general and operative description, as usual leaving out all most intuitive elements and, 

anyhow, to be necessarily completed by a direct hands-on experience. 

The main subject on this Virtual monitor (or Visualizer) is the Soundtrack associated to the current 
Video, represented as a Waveform running on a horizontal Timeline (in:  hh:mm:ss). Here a typical 
display, where you see what “happens”, in sound terms, around the 10th minute of the Play, as indicated 
by the vertical green line, as the playback Position marker; and the vertical amplitude of the Waveform 
that represents the sound level as function of time. Of course Soundtrack and Video Timelines should 
be exactly the same thing35. 

On this Virtual monitor, when void, you'll see a “Click to add waveform” caption, suggesting an action 
equivalent to the Video > Open video file… command [cf.]. 

□

Now, assuming that your Video has got a Subtitle file to be opened via File > Open command, you will 
see, laid upon distinct segments of the Waveform stream, 

single Records of the Subtitle file, as printed on a transparent slide with, on the background, a squared
grid horizontally graduated in 10th of second, here conveniently named Subtitle Unit [SubUnit, in short].
On each Unit you'll see the Subtitle text and some other data such as the record's Number and Duration
[cf. sct.:  Subtitle View]. Note that between subsequent SubUnits you'll see “Gaps”, that is segments of
Waveform  with  no  SubUnit  superposed.  Currently  executing  SubUnit  is  put  in  evidence  by  the
corresponding Waveform turned red-colored,  all  other  Waveform flow is  kept  usual  green-colored.
Now a look at the various controls and commands here available. 

35 Anyhow, if not, there is absolutely nothing that SE can do about [cf. sct.:  Concepts \ Time]. 
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□

Soundtrack Controls and Actions 
Here too, as usual in this Tech.Report, not absolutely ALL Controls and possible consequent user's

Actions are to be described, as it would be both unpractical and unnecessary. Indeed, some are left to
the hands-on user's experience, anyhow obviously indispensable. 

 

 when ticked—default condition—, the List view results 
synchronized with the running Soundtrack, the current Subtitle record results 
selected, and current SubUnit results red-colored. 

notice here the vertical green-line playback Position marker, click positionable, 
and the shift-SubUnit hand pointer. 

 “Play / Pause”, “Center” (the exec-point on the virtual screen) and 
“Play speed rate” 

□
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Soundtrack Context Menu 

Hint: shift-drag  to select, 
 click outside to deselect. 
 
Notice: Record Units cannot be 
 selected this way, act on the 
 List view instead.- 

□

Context on Soundtrack Segments:  Selected, Active and Gap 
Distinct sets of context commands here, in this section, considered together, in sequence. Same

command not repeated. 

Warning 
<~> Alas some menu items are here actually out-of-context, and therefore both useless and 

misleading. Such as:  “Go to” subtitle commands with no subtitle available, and so on… And that 
shouldn't be, as accuracy in composition of context menu is crucial to grant operative efficiency. 
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□

Command List 
Add text here Add text from clipboard here 
 
Focus text box Go to previous subtitle Go to next subtitle 
Delete text Split Merge with previous 
Merge with next Extend to previous Extend to next 
Play selection Add / Remove scene change Guess time codes… 
Seek silence… Insert subtitle here… 
 

□

(^) Add text here 
(^) Add text from clipboard here 

Insert the clipboard contents or what will be typed into the Text frame into the currently selected
segment  of  Soundtrack,  this  way  transformed  into  a  SubUnit.  Note  that  only  Void  segments  of
Soundtrack can be selected, and possibly become new SubUnits. 

□

(^) Focus text box 
To select in the List  view the text of the Subtitle record corresponding to the currently click-

pointed SubUnit. 

Viewpoint 

<~> Shouldn't be uselessly available also off-context, that is:  without a Subtitle file, or in Source
view [see]. 

□

(^) Go to previous subtitle 
(^) Go to next subtitle 

To jump to prev/next Subtitle Unit with respect the currently click-pointed one. 

Viewpoint 

<~> Shouldn't be uselessly available also off-context, that is:  without a Subtitle file, or “prev” at
first SubUnit, or “next” at last [see]. 

□

(^) Delete text 
To delete the whole Subtitle Record on the current SubUnit (Ctrl+Z to Undo, as usual). 
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Viewpoint 

<~> Both terms “text”, in the very command, and “line”, in the consequent confirmation window,
are ambiguous and misleading, as the whole Subtitle Record is here referred to, and with all its Fields:
record number, time parameters and text; with all the following Records consequently re-numbered. 

□

(^) Split 
Split a SubUnit in two, at the current position of the vertical green-line Position marker. A look at

the new List view is then advisable, as an error condition may arise. 
□

(^) Merge with previous 
(^) Merge with next 

Merge current SubUnit with the prev/next one. A look at the new List view is then advisable, as an
error condition may arise. 

□

(^) Extend to previous 
(^) Extend to next 

Extend current SubUnit up to prev/next one, that is:  including existing “Gap”. 
□

(^) Play selection 
Play just  the Subtitle Record Unit36 currently selected on the Soundtrack Virtual monitor,  then

pause. Notice that also a segment of Void Timeline can possibly be “shift-drag” selected, and then
played [see above sct.:  Soundtrack Context Menu, initial Hint and Notice]. 

Remark 
Notice  a  rather  similar  “F5”  shortcut  command  [see  sct.:   Shortcut  Commands],  whose  main

difference lies on the Record selection, made acting on the List view instead of, as here, directly on the
Soundtrack Virtual monitor. 

□

36 <.> By the way:  describing such command as this one, the term and concept of Subtitle Unit results particularly useful 
[cf.:  Subtitles:  Terms & Concepts]. 
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Text Permanence 
In default  Options > Settings… condition, and selected the “mpv”  Video player [see], at the end of

each  (^)  Play  selection command  execution  the  Subtitle  text  will  disappear  from the  screen.  Same
behavior also with the similar “F5” shortcut command. In case you'd prefer otherwise, you may just
clear the related “mpv handles preview text”37 check box, so to get the desired text display permanence. 

But, alas, that comes at a price:  instead of having the Subtitle text written “over” the video image, as
usual, you'll have it set on a dedicated stripe, so reducing the video surface, as hereafter shown. 

 

<~> Another related inconvenience—probably a minor bug, or simply an oversight—is that the same
Subtitle text permanence doesn't occur operating with the otherwise equivalent “Play” actions, in the
basic task “Translate” mode [cf.]. 

□

37 <~> Whose precise meaning and role, apart from this specific effect, is anyhow unknown to us. 
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(^) Add scene change 
(^) Remove scene change 

 <Insufficient information> – Report suspended 

 

All we know so far about “Scene change” and “Scene Change Detection” (SCD) is that it is a subject in
itself, worth attention and further analysis and investigation. And that, sometimes, it may be useful in
setting the Subtitle Units Start / End time according to specific rules, e.g. as by Netflix's. 

□

Operatively, here we just consider that, with this  Add /  Remove command, a “scene change” can be
marked with a vertical white line on the Waveform at the current vertical green-line Position marker; 
or then removed, precisely pointing at an existing one [cf. also:  Video > Generate/import scene changes…].

-<>-
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(^) Guess time codes… 

 <Under revision> – for reasons as hereafter hinted [and marked with a:  <~>]. 

Presumably, <~> in spite of the rather inexpressive command name, it's an automatic procedure aimed
at creating a sequence of blank Subtitle Units, i.e. Records, along the Timeline where the Soundtrack is
likely to contain speech. Records to be then possibly filled with actual Texts. 

A tool based on the analysis of the Soundtrack according to parameters entered into the above control
form, as hereafter described. 

Controls 

Delete lines <~> not certainly “lines” is here intended, but Subtitle Units, that is Records, instead 
[cf.:  Subtitles:  Terms & Concepts]. 

block it is here assumed to signify a single “discrete” scan-interval on the Timeline. 

above / below [ref.:  average volume] to define an intermediate band of sounds volume—above a 
certain min. level (threshold of silence), below a certain Max. level (threshold of 
noise)—where speech is presumably located. Unfortunately parameters verified as:  

 <~> as unreliable. Indeed the resulting number of Units seems to be quite indifferent 
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to the actual two threshold values entered. For instance a “negative”-width band, that 
is:  a Max. value inferior to the min., will generate anyhow a non-empty set of 
speech-candidate Records. 

<~> and as unpractical. In the sense that this is a typical setting to be adjusted via try-
and-error, that is tuning just one value, for instance the min. or Max. threshold value, 
and leaving all the other settings unchanged. Unfortunately that cannot be easily done
because the form doesn't “remember” last entered values, and when re-called, even 
during the same command-session, it will be reset to all the same initial default 
values. 

long subtitles presumably:  Duration field of a Record, so to establish a maximum above which a 
Record will be split in two or, presumably, more. 
<~> Anyhow feature not tested because of the other above declared difficulties.- 

Viewpoint 
Our conclusion:  

<~> A rather interesting tool, well worth the effort of fixing at all the here stated <~> points. 
□

(^) Seek silence… 
To jump to the position along the Timeline where there is a condition of “silence”, as defined in the

subsequent dialog box. 

Then the exact numeric time-position possibly found is shown on the “Video position” box [at:  Create or
Adjust Tabs], besides being indicated by the vertical green Position line. 

Viewpoint 

<~> It would be nice to know haw to evaluate the “Volume” value [in:  decibel  (dB)], particularly
with reference to the Waveform squared grid scale. 

<~> We have also noticed that the same Seek, if Forward or Back, leads to different position values, and
that is presumably due to the fact that in one case it will indicate the start, in the other the end point of
the same interval. We wonder if we could get this same information in a more convenient way. 
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<~> We have also noticed that if no condition of silence is encountered, then there is no change in the
current “Video position”. We wonder if this “null” result could be simply, and more correctly, signaled
by moving the Video position to the end of the scanned Timeline interval. 

□

(^) Insert subtitle here… 
Insert all the Records of a given Subtitle file into a “Void” interval [ i.e.:  a “Void Unit”] starting from

the current position of the vertical green-line Position marker. In that it is different from otherwise
similar commands as:  (^) Insert subtitle after this line…, or File > Open [cf.]. 

Possible error condition may arise, as List view will show. 

-<>-
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Main Task:  Translate 

Controls 
Delay takes effect when both “Auto” conditions are set on38, and inserts the stated delay 

before playing each next Subtitle Unit. 

All other controls are here assumed as self-explanatory. 
□

Remark 

<.> “Translate” tab-page may be profitably used not only for the named main task [cf. sct.:  BT2 –

“Translate” a Subtitle file, multi-lingual], but also in other circumstances where careful watching over and
over specific film sequences and subtitles might be required. 

Viewpoint 

<~> Thus—our opinion—it would be nice if this “Translate” tab-page could operate also on a given
contiguous set of selected Subtitle Units, and not only onto single ones, as it is now. Besides here, on
the List view table, selection of more than one Record-Row is perfectly permitted, but ineffective, as
only the first one will be then considered. 
 <~> An illusory selection, permitted, but not respected; and as encountered in many other  SE's
operative circumstances which—our opinion—should be all thoroughly revised. 

-<>-

38 <~> Therefore we assume inappropriate and misleading to locate this control within the “Auto continue” area, as it 

equally belongs to the “Auto repeat” area too. 
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Main Task:  Create 

Controls 
Insert new subtitle at video pos insert, at the current Video position, a blank new Subtitle Record with 

initial default duration value of 1 sec39; and select it ready for new Text. 

Play from just before text shift the Video Position Marker precisely at the beginning of the 
currently “red”-selected Subtitle Unit, and Play. 

Go to sub position and pause same as former command [see], and pause the Playback. 

Set start /end time set the start / end time of the selected Record at the current “Video 
position” box value (Ctrl+Z to undo). 

Remark 
As a  rule  the  “Video  position”  numeric  value  and the  vertical  “green”  Video  Position  Marker

correspond reciprocally, so that acting on each of them is equivalent. 

-<>-

39 <~> Similar action via command (^) Insert has default duration of 2 sec [cf.]. We wonder if such values are hard coded 
or could be tuned somewhere. 
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Main Task:  Adjust 

Controls 
Set start and offset the rest almost as with next Set start time [cf.], with the “rest”—that is, all timing of

subsequent Records—consequently adjusted. 

Set end & go to next almost as with next Set end time [cf.], then go to next Subtitle Unit. 

Set start / end time set selected SubUnit start / end time at the current “Video position” value. 
<.> “Video position” in itself doesn't change any Subtitle time-field value, 
being conceived to control the position of Video Position Marker only. 

Play from just before text force anyhow Playback starting from the beginning of the currently 
selected SubUnit, as shown on the List view table; SubUnit red-colored, 
as usual. Same move as “Go to” here below [cf.], then Play. 

Go to sub position and pause same move as “Play” here above [cf.], then Pause. 

 shift “Video position”:  
  backward/forward, by fine/large steps. 

 display/set a precise numeric “Video position”, with reference to the time 
scale:  hh:mm:ss.msec – linked to Position Marker manual setting. 

Remark 

<…> We have noticed an automatic  rounding of the “Video position” numeric  value,  probably
worth further investigation. 

-<>-
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Main Command Menu 
S-PM 210500

Menu Bar, and Commands 
This the main Menu Bar, in its standard position just below the Title Bar, in its standard shape,

where all drop-down Command Menus can be called. The main subject of this section. 

Menu Index 
File Edit Tools Spell check Video 
Synchronization Auto-translate Options Networking Help 
 □
Each  and  all  command  menus  to  be  thoroughly  described  hereafter,  with  the  exclusion  of  such
operative details as keyboard shortcuts and Tool Bar icons, left to the initiative, and preference, of the
adventurous user.

<.> The “Untitled” name on the Title Bar refers to the current Subtitle file, not yet properly defined. 

-<>-
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File Command Menu 

 

Command List 
New Open Open (keep video) Reopen 
Save Save as… Restore auto-backup… Timed Text properties… 
Open original subtitle (translator mode)… Save original subtitle Save original subtitle as… 
Close original subtitle Open containing folder Compare… Statistics… 
Plugins… Import Export Exit 
 □

Remark 
This File > … menu may assumes two distinct compositions [see figure]: 

   a shorter one, with the usual “*.srt” SubRip Text format Subtitle file; 
   a longer one, in case of “*.ttml” Timed Text Markup Language and “*.xml” formats. 

A typical example of SE menu-adaptation to different operative conditions. As a rule, in this Report all
same menu's commands will be presented, no distinction whether they belong to a longer or shorter list.

□
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Viewpoint 
In all such cases—disconcertingly frequent with SE—, instead of having commands disappearing

and appearing according to some environmental operative conditions, we’d be strongly in favor of a
different  approach,  that  is  keeping  anyway the  same  commands'  presence,  just  possibly  dimmed-
disabled. That, in our opinion, would be much more appropriate and user-friendly. 

Indeed that of a “dynamic” presence of commands according to environmental condition is a typical
characteristic reserved to context menus, not to main menus, traditionally always kept constant in their
composition. 

□

File > New 
Create a brand new and empty “Untitled” Subtitle file and, in the same time, possibly close the

currently opened one, if any. In essence, designed to reset all conditions for a new Subtitle editing
session. 

□

File > Open 
Open an existing Subtitle file, whether recognizable as such. 

Main  SE subject  is,  indeed,  the Subtitle  file.  That  is  to say that  possible  opening of other  files—
typically video media files—are consequently subordinate40 to this primary purpose [cf. cmd:  Video >
Open video file…]. 

Prevalence of subtitle over video media is witnessed also by the fact that, inversely as with usual video
player programs, at the opening of a subtitle file SE may automatically open also a corresponding video
file, whether anyone is found nearby with the same subtitle's name and appropriate extension; and
provided such behavior is permitted by the “Auto-open video file when opening subtitle” check box on the
Options > Settings… : Video payer form [see]. But no analogous inverse automatism [that is:  Subtitle opening
after Video] is provided by SE. 

Remark 
Note here the—deliberate—absence of a corresponding “Close” command. To that purpose just use

the  File > New command instead [see],  which is precisely provided to do all required housekeeping
actions. Or, equivalently, try open another Subtitle file, which will imply a neat closure of the possibly
current subtitle editing session first. 

□

File > Open (keep video) 
Same as “Open” [see], just keeping the same video currently opened. 

□

40 Subordinate in various and intuitive ways, that we are not going to describe here in detail. 

 – 63 –  



Subtitle Edit Main Command Menu  Technical Report

File > Reopen 
Designed to display the History-list of the last opened Subtitle files, handy to possibly re-open

again one of them. 

Remark 
Command not available, nor shown, in case of an empty History-list, that is to say just initially, or

after a File > Reopen > Clear, or after an Options > Settings… > Restore default settings > OK button action
[see – see also the Viewpoint stated under sct.:  File Command Menu]. 

□

File > Save 
Save overwriting the currently open Subtitle file, without closing the editing session. In case of a

“Untitled” file, this command operates like “Save as...” [see]. 

Remark 
SE “Cannot save empty subtitle”, 

so you'll be told on the bottom Status Bar in case you'd try doing so. 
□

File > Save as... 
The very same as with the other “Save” command [see], but onto a file possibly different in:  name,

location, type and extension. 

Type and extension to be chosen among those shown available on the related “Save as type” drop-down
list:  SubRip (*.srt), ABC iView (*.xml), …, Unknown 103 (*.txt); possibly implying a conversion. Same drop-
down Format list of the Tool Bar [see]. 

Remark 
As a rule SE deals with Subtitle files of text format, as primarily the popular SubRip's “.srt”; that is: 

not binary image files [cf.:  Subtitles:  Terms & Concepts]. Binary text formats are exclusively subject of 
the dedicated File > Import and Export commands [see]. 
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□

File > Restore auto-backup... 
Nice to know that SE grants such an auto-backup mechanism, typically useful to possibly recover

Subtitle files previously automatically saved so, for instance, to limit damages after a system crash. 
 

 

As  usual  with  SE,  a different  containing  folder  is  assigned  to  each  single  user,  this  way:
C:\Users\User103\AppData\Roaming\Subtitle Edit\AutoBackup 

□

File > Timed Text properties… 

 <Not Covered> – Off-Report 

Highly specialized “properties” form, in connection with the  Timed Text Markup Language “*.ttml”
Subtitle file format [and, it seems, also with:  ASSA, ebu stl formats]. 

Remark 
Currently [S-PM 210000], we privilege the most popular “*.srt” Subtitle file format, then only look 

with discreet attention to such other Subtitle formats, possibly ready to evaluate their diffusion and 
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relevance. 
□

File > Open original subtitle (translator mode)… 

When engaged in a “Translate” task [see sct.:  BT2 – “Translate” a Subtitle file] it may be handy to open
also the original Subtitle file of which the current one is the translation. 

Remark 
Useful here to know about the “ToggleTranslationMode Control+Shift+O ” Shortcut command [see]. 

□

Viewpoint 

  <Insufficient information> – Report suspended 
Further tests and inquires required to issue a valid Report 
[cf. also cmd:  Tools > Make new empty translation from current subtitle]. 

□

File > Save original subtitle 
File > Save original subtitle as… 
File > Close original subtitle 

Usual command [cf.] just acting on the current “original” Subtitle file, in “translator mode” [see]. 

Viewpoint 

<~> As a rule, any original text, be it a novel, an article or a subtitle, shouldn't be changed while
under  translation,  being  its  role  that  of  a  read-only reference.  Therefore  we consider  here  utterly
inappropriate and “dangerous” to dispose of any “Save” command for an “original subtitle” in such a
circumstance. 

□

File > Open containing folder 
Just to open the directory containing the current Subtitle file, for inspection or so. 

□

 – 66 –  



Subtitle Edit Main Command Menu  Technical Report

File > Compare… 

In this example, for instance, it is to tell the difference between the same Subtitle file, in “ .ttml” and
“.srt” format, with different sync Timestamps. 

□

File > Statistics… 

To display and export such kind of info about the current Subtitle file. 
□
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File > Plugins... 
A way for adding special functionalities beyond those offered by the standard SE program. 

With this command you may explore which SE-Plugins are available in the dedicated “raw.github.com”
Internet site, and which one have been possibly already downloaded into your local depot, that is: 
 … \Users\myUserName\AppData\Roaming\Subtitle Edit\Plugins 

Remark 
Detailed description of the currently available SE-plugins, or how to possibly develop them, is at

the moment beyond the purpose of this Report. 
□

File > Import 
File > Export 

Interchange and conversion commands for files of special formats, other than those dealt with the
usual  File > Open and > Save commands [cf. – see also 2nd Remark, that about Text/Binary format files, at sct.:
Subtitles:  Terms & Concepts]. That is, formats spanning from plain text to Blu-ray (.sup), as available
through the related drop-down lists of these very commands. 

□

File > Exit 
Close the current SE session, and perform all related house-keeping. 

-<>-
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Edit Command Menu 

Command List 
Undo Redo Show history (for undo) Insert Unicode symbol Find 
Find next Replace Multiple replace… Go to subtitle number… Right-to-left mode 
Fix RTL via Unicode control characters (for selected lines) 
Remove Unicode control characters (from selected lines) Reverse RTL start/end (for selected lines) 
Modify selection… Select all 
 □

Text Edit Area 
Before going into detail about each and all Edit Menu Commands let's have a look at the work area

where these commands operate. 

A Subtitle file is composed of single text-items as here listed into a table, in numbered rows and with
related timing property-columns [hh:mm:ss.msec]; all editable by means of dedicated controls, self-
explanatory enough not to require much explanation. 

 – 69 –  



Subtitle Edit Main Command Menu  Technical Report

Text selected Subtitle's text-edit box 

Chars/sec Total length41 / Duration ratio (e.g.: 13.14 Chars/sec), that is the implied reading speed
– ref. upper limit for an average viewer:  20 char.s/sec 

Single line length e.g.:  10 and 31 char.s, two lines42 

Total length e.g.:  41 char.s 

Unbreak / Auto br buttons to reset / add automatic break-lines 
□

Edit > Undo 
Edit > Redo 
Edit > Show history (for undo) 

Designed to perform the named usual editing actions. Commands conveniently dimmed-disabled
when not usable, that is when there is no former action to undo/redo/show. 

Viewpoint 
As already said [cf. footnote at  Title Bar], we consider this way of declaring disabled a command,

when unusable, much preferable to not displaying it at all. And, for obvious reasons of uniformity, so
not to disconcert  the poor user,  we are strongly in favor of adopting always this  same convention
wherever required, as for instance also with File > Reopen and File > Export commands [see]. 

□

41 Conventions:  exclusion of html and ASSA tags for Italic, Bold and Underline characters; and possibly the exclusion of 
spaces according to Options > Settings… : General \ Chars/sec (CPS) includes spaces [see]. 

42 <~> Text lines, table rows and Subtitle records are distinct terms and concepts, of course. Not to be confused as, for 
instance, erroneously done in such a command as:  Insert subtitle after this line…, or:  Extend to line before [see, 
and see also sct.:  Subtitles:  Terms & Concepts]. 
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Edit > Insert Unicode symbol 
Designed to insert into the pointed position of the Text frame one of the here available Unicode

symbols. That is:  

Symbols that may be useful to have here handy, being not available on usual keyboards. 
□

Edit > Find 
Edit > Find next 
Edit > Replace 

Usual edit-commands, assumed as universally known. 

□
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Edit > Multiple replace… 
Offer a form for an advanced Find & Replace editing tool43, making use of standard text search

lists and regular expressions. 
 

 

A tool  aimed  at  translators,  editors  and  DeskTop  Publishing  (DTP) specialists, whose  operative
description would go beyond the purpose of this Report and deserve a dedicated booklet of its own. 

Remark 
A look at:  Edit > Modify selection… for another powerful “composable” search text tool. 

□

Edit > Go to subtitle number… 
Designed to quick jump to and select a numbered row on the Subtitle table. 

□

Edit > Right-to-left mode 
Edit > Fix RTL via Unicode control characters (for selected lines) 
Edit > Remove Unicode control characters (from selected lines) 
Edit > Reverse RTL start/end (for selected lines) 

Designed for dealing with “Right-To-Left” languages, as Arabic and Hebrew [that's all we can here
say, being that a cultural environment unknown to us]. 

□

43 As can be found with Excel or Digital Workroom's “Noted” application. 
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Edit > Modify selection… 
Powerful multi-section logically composable Subtitle text search and select tool. 

 

Edit > Select all 
Designed  to select  all  Subtitle  records  on  the  List  view  and  all  corresponding  Units  on  the

Soundtrack Virtual monitor. 

-<>-
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Tools Command Menu 
 

 

Command List 
Adjust durations… Apply duration limits… Bridge gaps between subtitles… 
Apply minimum gap between subtitles… Fix common errors… Renumber… 
Remove text for hearing impaired… Change casing… Merge short lines… 
Merge lines with same text… Merge lines with same time codes… 
Break/split long lines… Sort by Netflix quality check… 
Make new empty translation from current subtitle Batch convert… Measurement converter… 
Split subtitle… Append subtitle… Join subtitles… 
 

Requisite 

<.> Most of these Tools commands require the presence of a Subtitle file. 

□
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Tools > Adjust durations… 
Tool for a rough general Subtitle duration adjustment fit for languages of remarkably different

average word lengths, typically in case of a transition between oriental and occidental languages. 

Seconds / Percent referred to the Duration of all Subtitle records. 

Recalculate each Duration, based upon the given char.s per second speed parameters. 

Remark 
Worth recalling that a  good average top reading speed is  about  three word/sec,  that  is  around

20 char/sec, with occidental languages. For instance, Netflix standard limit is a prudential 17 char/sec. 

Extend only no Duration reduction admitted, only extension. 

Fixed same value for all Durations. 

□
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Tools > Apply duration limits… 
Command to force time Duration limits to all Subtitle records. 

“Fixes available” and “Unable to fix” tables are shown at call, permitting possible manual interventions.
Actual command's action takes place only on “Apply-ed” records, and after “OK”. 

□

Tools > Bridge gaps between subtitles… 
A tool for tuning “Gaps”, that is time intervals between contiguous Subtitle records [see:  Subtitles:

Terms & Concepts], according to the following scheme. 

-----+----|-----+-----]----+----->
 -g 0 g G V t 

• Proper Gaps should be short enough not to permit the insertion of any significant Record in 
between, short interval as represented with segment |0 - G] in the above scheme. 

• Gaps longer than that are more properly considered simply as void intervals between Records, 
as represented with segment “0 - V” in the above scheme. 

• Any position between “g” and “G” are here considered as substantially equivalent, and can be 
assigned the same time value “g” indicated in the above scheme. 

• “Negative” Gaps represent a Subtitle records' overlapping, that is an error condition; 
<~> curious that here no provision is taken to possibly fix them. 
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Bridge gaps corresponds to the “G” value in the above scheme. In this example only Gaps ≤ 100 
and > 24 msec will be chopped to 24 msec; all the others are left as they are. 

Min. milliseconds corresponds to the “g” value in the above scheme. In this example:  24 msec. 

Previous text possible time correction is assigned only to the Record at left of the Gap; 

Texts divide possible time correction is equally assigned to both contiguous Records. 

□

Viewpoint 

<.> In this tool frame is particularly evident how relevant is a clear, unambiguous and coherent
adoption of terms [as stated in:  Subtitles:  Terms & Concepts], and how confusing, almost unmanageable
are instructions expressed with unappropriated, imprecise terms. 

□
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Tools > Apply minimum gap between subtitles… 
Just to ensure that all Subtitle Gaps be greater than a given minimum value [e.g. here:  24 msec].

Possible adjustment affects lower Gap's limit only, upper remains unchanged. 

Controls 

 <Inquiry> – About:  

Frame rate info not clear whether it's an information Mr. User is supposed here to receive or to enter. 
And, if the second, we wonder how Mr. User can know. And, above all, its meaning 
in this context. 

Frames “fps” (frame per second) is a value of frequency, given here also as its inverse, the 
“period”, namely the time interval between two cyclic events; frames, in this case. Or 
possibly more than two, so, we presume, to increase the precision. To be confirmed. 

□

Remark 
It may be worth recalling that there is a simple relation between duration of a film and the above

cited Frames parameter, i.e.:  “fps” (frame per second). It is:  
t = t * n

Where:  
t elapsed time, that is:  duration of a film, or of a given fraction of it. 
t “period”, that is:  duration of one cycle; in this case:  the display of one frame. 

 being:  t = 1/f, that is:  the inverse of the “frequency” [f]. 
n number of frames in a given frame-sequence, be it a film or fraction of it. 

 

 – 78 –  



Subtitle Edit Main Command Menu  Technical Report

This same formula expresses also the basic relation between “time-[t] based” vs. “frame-[f=1/t] based”
Subtitle sequence44. 

□

Tools > Fix common errors… 
Powerful tool, in two steps; mostly self-explanatory. 

Controls 
Select refers to action check-boxes. 

Next no action before next step [see], from which one may always return to this first. 

□

Second step, where to possibly perform manual actions too. 

44 <.> Cited  f, t, n parameters are specific of any given film, and it would be nice to find out a tool for reading them. 

Such a tool could be the program MediaInfo [see:  https://mediaarea.net/ ], alas also practically undocumented. 
<~> We wander if SE could be entrusted with such a useful feature too... 
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Controls 
Select refers to action check-boxes. 

Back to preceding step [see]. 

OK available after “Apply selected fixes”, meanwhile Subtitle file remains unaffected45. 

□

Tools > Renumber… 
Sort of “refresh” Subtitle records numbering, possibly messed-up. 

□

45 By the way, that's why here, apparently, “Ctrl+Z” (Undo) doesn't work:  it does, but possibly only after a final “OK”. 
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Tools > Remove text for hearing impaired… 
Subtitles declared “for hearing impaired” contain also sort of “description” of sounds and noises,

which this command is aimed to remove so to get the ordinary version of the same Subtitles file. It isn't
infrequent to leave then both file-versions—ordinary and for hearing impaired—to the user's choice. 

A form self-explanatory enough not to require any further description. 
□
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Tools > Change casing… 
Activate a specific Upper/lower case style according to possibly different conventions and rules46,

valid for all the current Subtitle file – in that different from the otherwise identical context command:
“(^) Change casing for selected lines…” [see], which refers to the selected Subtitle records only. 

A control form self-explanatory enough not to require any further description, but for:  

(via Dictionaries\names.xml)47 dictionary of the recognized Names, which may be:  
 • inspected via “Open 'Dictionaries' folder”, command Spell check > 
Get dictionaries… [see]; 
 • customized via “Add to names/noise list”, command Spell check > 
Spell check… [see]. 

Remark 
This same Names dictionary is used by “Change casing…” commands [see] and OCR tool [SE tool

here not yet tested, nor documented]. 
□

46 E.g.:  UPPERCASE to signify words pronounced aloud / Text in German language, with all nouns capitalized / … 
47 More precisely, e.g.:  C:\Users\User103\AppData\Roaming\Subtitle Edit\Dictionaries\de_names_user.xml 
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Tools > Merge short lines… 

<?>  What  this  command  does  is  clear  enough,  but  for  the  following  details  deserving  precise
definition:  

… short lines apart from the ambiguity of the term “lines” [see questions hereafter], what does it 
mean precisely “short”? 

… one paragraph no idea what here this term precisely means [cf.:  Subtitles:  Terms & Concepts, please
do] 

… between lines same as before, but the “suspect” that it stands for Subtitle Units 

… continuation lines same as before 
□
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Tools > Merge lines with same text… 

<?> As with the preceding one [see], what this command does is clear enough, but for some details
deserving precise definition:  

Max milliseconds between lines “same text” check is executed only within such time-Gap, 
<~> of course time-Gap between Subtitle records, nothing else. 

Include incrementing lines <?> no idea what an “incrementing line” is; 
<~> again, as ascertained all over in this Report, all SE-terminology 
should be totally and accurately revised. 

□
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Tools > Merge lines with same time codes… 

With this command, as shown in the example above, two Subtitle records with “almost” the same
timestamp—that is:  Start time and Duration—can be merged into one. 

Max millisecond difference what “almost” means:  within the stated difference 

… lines <~> here again:  the same word “lines” used with a completely different
meaning in “Merge lines”, referred to Record, and “Re-break lines”, 
referred to Text. 

□

Tools > Break/split long lines… 

 <Inquiry> – About:  

Although, in principle,  clear enough, about this Tool we have just questions to ask, instead of
explanations to offer.  Questions mainly due to the inextricable ambiguity of the terms here in use.
Anyhow, these are the facts. 

□
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0)  Test starting point is this Subtitle file “CantoN0.srt”, initially comprising just one very long, 
deliberately abnormal Record:  
1
00:00:01,000 --> 00:00:03,000
"Night Song of a Wandering Shepherd of Asia" -- "Canto notturno di un pastore errante dell’Asia" 
(Giacomo Leopardi, 1831)

Che fai tu, luna, in ciel? dimmi, che fai, Silenziosa luna?
Sorgi la sera, e vai, Contemplando i deserti; indi ti posi. 

What do you do, moon, in the sky? Tell me, what do you do, Silent moon?
You rise in the evening, and go, Contemplating the deserts; then you stand. 

□

1)  A first “OK” execution of Tools > Break/split long lines… generates this “CantoN1.srt”, two Records:  
1
00:00:01,000 --> 00:00:01,985
"Night Song of a Wandering Shepherd of Asia" -- "Canto notturno di un pastore errante dell’Asia"
(Giacomo Leopardi, 1831)  Che fai tu, luna, in ciel? dimmi, che fai, Silenziosa luna? Sorgi la sera,

2
00:00:01,997 --> 00:00:03,000
e vai, Contemplando i deserti; indi ti posi.  What do you do, moon, in the sky? Tell me, what do
you do, Silent moon? You rise in the evening, and go, Contemplating the deserts; then you stand.

□
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2)  A second execution of the same command generates this “CantoN2.srt”, four Records:  

1
00:00:01,000 --> 00:00:01,471
"Night Song of a Wandering Shepherd of Asia" --
"Canto notturno di un pastore errante dell’Asia"

2
00:00:01,483 --> 00:00:01,985
(Giacomo Leopardi, 1831)  Che fai tu, luna, in ciel?
dimmi, che fai, Silenziosa luna? Sorgi la sera,

3
00:00:01,997 --> 00:00:02,487
e vai, Contemplando i deserti; indi ti posi.  What
do you do, moon, in the sky? Tell me, what do

4
00:00:02,499 --> 00:00:03,000
you do, Silent moon? You rise in the evening, and
go, Contemplating the deserts; then you stand.

□

3) A third and last execution of the same command generates this “CantoN3.srt”, eight Records:  
1
00:00:01,000 --> 00:00:01,221
"Night Song of a Wandering
Shepherd of Asia" --

2
00:00:01,233 --> 00:00:01,471
"Canto notturno di un
pastore errante dell’Asia"

3
00:00:01,483 --> 00:00:01,729
(Giacomo Leopardi, 1831)
Che fai tu, luna, in ciel?

4
00:00:01,741 --> 00:00:01,985
dimmi, che fai, Silenziosa
luna? Sorgi la sera,

5
00:00:01,997 --> 00:00:02,243
e vai, Contemplando i
deserti; indi ti posi.  What

6
00:00:02,255 --> 00:00:02,487
do you do, moon, in
the sky? Tell me, what do

7
00:00:02,499 --> 00:00:02,745
you do, Silent moon?
You rise in the evening, and

8
00:00:02,757 --> 00:00:03,000
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go, Contemplating the
deserts; then you stand.
 

At this point, after three distinct steps, the command “Tools > Break/split long lines…” declares that, in the
present condition, it has done all what it could do. 

□

Thus, here follows the related final image, and the related questions. 

Questions 

<?> Instead of guessing, we'd like to have neat and precise description of the following terms, and
of their use48. 

long lines in Title caption “Break/split long lines”, being unclear if the actions “Break” and “split” 
refer to the same or to different things. 

Single line in caption:  “Single line maximum length”. 

Line in caption:  “Line maximum length”. 

Line continuation and strings 
in caption:  “Line continuation begin/end string”. 

48 Of course glad to collaborate to this clarification process as done with sct.:  Subtitles:  Terms & Concepts [see]. 
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Line and Text as in the tables' heading, whether and how they related with the terms found in the 
other captions, where, by the way, the term “Text” never appears; 

single line and then line in the same caption:  “Longest single line length is nn at line n” 

total line and then line in the same caption:  “Longest total line length is nn at line n” 

<?> Required: neat, precise, unambiguous definition of all these terms, and of their use. 
□

Tools > Sort by 
Re-order all Subtitle records according to the chosen criterion. 

That's, for instance, to:  

• Compare and evaluate the overall “Words per minute” 
(WPM) speed spread, but then to restore the original 
numeric order; 

• Reset all Records' position according to the actual Start 
time values, so to then re-order them via Tools > Renumber…
command [see]. 

□

Tools > Netflix quality check… 
Tool aimed at  performing a thorough Subtitle “quality check” in conformity with the standard

Netflix rules49. 

Professional Subtitles should be created according to well defined style-rules affecting for instance
duration, speed and length, as here may be also defined via Options > Settings… : General [see, see also:
Viewpoint, at sct.:  Chronicle of a basic “Create” experience]. 

49 Netflix, Inc. a renowned American multimedia production company, recently (2021) acquired by Amazon. 
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The example here shown is drawn from a—of course non-Netflix—Subtitle of a primary German TV-
News  service,  where  this  check  has  found  that  more  than  half  Subtitle  items  were  non-Netflix
compliant, that is at a first  SE-default run. Then, at second run, with unchecked “Frame” conditions
[see], this amount was drastically reduced. 

Notable points:  

Function fault explained 

Suggested fix how to possibly fix it 

 … issues fault count 

Open report in folder to get handy detailed description of all faults on a file; e.g.:  
“Original–Tagesschau-tagesschau, 14_50 Uhr-0136664133_NetflixQualityCheck.csv” 

LineNumber, TimeCode, Context, Comment 
3,00:00:05.680, "CPS=19.07", "Maximum 17 characters per second" 
5,00:00:16.160, "", "Text can fit on one line" 
17,00:01:02.880, "", "From 1 to 10, numbers should be written out:
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  one, two, three, etc" 
26,00:01:37.360, "", "Text can fit on one line" 
31,00:01:55.600, "", "Text can fit on one line" 
41,00:02:29.400, "CPS=18.21", "Maximum 17 characters per second" 

□

Tools > Make new empty translation from current subtitle 
Activate  a  “translation”  operating  mode for  the  current  Subtitle  file,  consisting  mainly in  the

creation of a new empty Subtitle file to be shown and edited besides the original one; as illustrated in
the figure below, where then it appears evident the hereafter described Bug [see]. 

As a result, at closing of the such SE-session, you'll be permitted to save both the “Original” and its
“Translation” new file, to be then conveniently opened into subsequent actual translation SE-sessions.
That is:  opened in “translation mode”, along with its companion “Original” file. 

□

Consider also that “Translate”, with “Create” and “Adjust”, is one of the three  Subtitle Edit's “Main
Tasks”, deserving an SE tab-page of its own [cf. sct.s:  BT2 – “Translate” a Subtitle file, multi-lingual, and Main
Task:  Translate]. 

Bug:  <?> Notice that, in this initial image, “Original text” and new “Text” captions are misplaced on the
respective editing text boxes, in contrast with the respective List views, and the common sense. 

Viewpoint 
As a command aimed at creating a new Subtitle file, it seems more appropriate to locate it into the

File menu rather than here, in this Tools menu [cf. anyhow cmd.:  File > Open original subtitle (translator
mode)…].  And,  anyhow, being not  a  context  command,  it  should  remain well  visible  in  its  menu,
although disabled when inapplicable; and not disappear as now happens. 

□
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Tools > Batch convert… 
Powerful tool of Subtitle file conversion, possibly acting also on “batch” of files, instead of on a

single  one,  as  with  “Save  as...”  and  “Export”  commands  [see];  and  that  according  to  a  variety  of
“Convert options”. 

Multiple Input Options:  

browse , drag-n-drop 

Scan folder…, Include sub folders, and  

Multiple Output Options:  

Convert options SE-default:  none checked50, last user's setup recorded 

50 No systematic conversion tests are here programmed:  user's suggestion/remarks are welcome. 
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Save choices 

Format, Encoding encompass all variety of choices as with Save as… and Export [cf.] 

Convert single execution, conversion session may continue 

OK end-of-conversion session 

□

Tools > Measurement converter… 

Nice to know it's there, just handy & useful. 
□

Tools > Split subtitle… 
A tool to split  a Subtitle  file51 into two or more parts,  when for any reason required,  e.g.  for

manageability [cf. inverse command:  Tools > Join subtitles…]. 

Basic Control Form 

Hour:min:sec.ms initial default:  video timing 

51 <.> “file”, indeed. As already remarked [see:  Subtitles:  Terms & Concepts], most of the times, as here, the term 
“Subtitle” in itself is too generic to be significant. Therefore, to be significant, you have to specify whether you are 
talking about a Subtitle file, or Record, or single record Text, or single record text Line, or Timestamp, or Unit, or 
Fragment or whatever else; as we are committed doing throughout this Report, and we strongly advocate should be done
throughout the entire SE program too. 
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Advanced (/ Basic) toggle between Split control forms 

Split execute 

Done close session 
□

Advanced Control Form 

Controls 
Split all controls here assumed self-explanatory enough not to require any further 

description 

Remark 
By the way, here are shown some rather useful synthetic dimensional data about the Subtitle file 

[cf. and see also:  File > Statistics…]. 
□
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Tools > Append subtitle… 

 <Inquiry> – To clarify:  When, in which circumstances this Tool may be useful. 

Questionable dialog box instructions 

append an existing subtitle what is to be “appended”, a single Subtitle record or a Subtitle file? 

currently loaded subtitle we don't know what a “loaded subtitle” is – may it be:  “Opened”? 

be in sync what does this requisite mean, in real, operative terms? 
□

Continue:  

<.?.> Anyway, looking at this control form, it's evident that this is not a plain “Append” tool, and we'd
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like to know what it is, even before trying using it. We wonder if it could be considered a sort of
command (^) Insert subtitle here… combined with Synchronization > Visual sync… [see]. 

□

Tools > Join subtitles… 
It's to join Subtitle files, as inverse of Tools > Split subtitle… [see]. As such, this command is enabled

to work also at a fresh File > New condition. 

Controls  
#Lines Subtitle records count [<~> original caption rather imprecise] 

Join execute, then close [other controls assumed self-explanatory] 

-<>-
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Spell check Command Menu 

Command List 
Spell check… Find double words Find double lines 
Get dictionaries… Add word to name list 

Requisite:  <.> Most of these Spell check commands require to operate on a given Subtitle file. 

□

Spell check > Spell check… 
Perform a spell check on the current Subtitle file, provided the required dictionary is available [ if

not, see further on in this sct.]. 
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Controls 

Language choose the desired language, or get it via:   [see next sct.:  Dictionary Needed] 

Change manual editing 

Add to … to personalize current dictionary 
<.> Feature available also as a sub-command:  Spell check > Get dictionaries… [see]. 

All other controls are here assumed as self-explanatory. 

□

Statistics, at End of Job 
 

 

□

Dictionary Needed 

NHunspell engine that is “New Hunspell” (by László Németh, Hungarian biologist and s/w developer) 

Choose ... among possibly more than one dictionary; e.g.:  Deutsch, English (five varieties:  AU,
CA, US, ZA [←South Africa Internet country code], GB); 
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Open 'Dictionaries' folder to inspect the already available ones, in:  
C:\Users\User103\AppData\Roaming\Subtitle Edit\Dictionaries 
[requires “Show hidden folders” system option enabled, to be seen] 

<.> Feature available also as a sub-command:  Spell check > Get dictionaries… [see]. 

□

Spell check > Find double words 
Just find, what to do then is up to you. 

Result given on the bottom Status bar, included the “regex” (regular expression) in use. 
□

Spell check > Find double lines 
Search of a possible  first pair of consecutive Subtitle records with identical Text, if any; located

after a given selected Record, or throughout the entire Subtitle file when no Record selected. 

If any found, consequent editing action is left to the user. No automatism. 

Remark 

<~> This command deals, of course, with Subtitle Records Texts, not Lines [ref. to:  Subtitles:  Terms

& Concepts].  As  already noted,  SE User  Interface  terminology is  rather  inaccurate,  and should  be
thoroughly revised and mended. 

□
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Spell check > Get dictionaries… 

As with Spell check > Spell check… [see], of which it is a sort of sub-command. 
□

Spell check > Add word to name list 

As with Spell check > Spell check… [see], of which it is a sort of sub-command. 

-<>-
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Video Command Menu 

Command List 
Open video file… Open video from url… Close video file 
Open second subtitle file… Set video offset… SMPTE timing (drop frame) 
Generate/import scene changes… Batch generate waveforms… Generate blank video… 
Generate video with burned-in sub… Show/hide waveform Show/hide video 
Un-dock / Re-dock video controls 
 

Requisite 

<.> For optimal  SE performance it is recommended, at the first  Video > Open video file… call, to
accept to Download and use “mpv” video player library, if suggested by a possible SE-error box. Then a
look at the Options > Settings…, to check the current status of Video player \ Video engine. 

Remark 
The above cited “Download and use “mpv” as video player” caption [cf.] is somehow misleading, as it

would let you think that, accepting to push this button, then you will be using MPV as your video
player. Well, it's not precisely so, as then it will be SE using the MPV's “.dll” library to manage video
files, not you. Here MPV is not a program that you could use directly, but a nice good “ .dll” library,
possibly callable by a program using it. For your direct use you'll be possibly using the same media
player program you were using before. 

By the way, another possible action for performing the here considered initialization would be to call
the menu command Options > Settings…: Video Player / Video engine [see], and choose VLC as your media
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player instead, in case you were already using it. But, at the moment, this is not recommended, because
of its current poor performances by comparison with MPV's, if evaluated from the SE point of view.
That's so, for now.

□

Viewpoint 
Video menu command as printed at the top of this section is that one appearing  after opened a

video file, rather different from the same you'd get before, as you may compare here below [cf.]. 

Not as much different as it was in the former  SE rev. 3.6.1 [cf. here below], but still a different list of
eleven command, instead of thirteen. 

<~>  As said in other similar occasions allover this program, this is a difference that we find rather
confusing, therefore we are in favor of the usual way of keeping unaltered the same drop-down list of
menu commands, just possibly disabling those for some reason currently unusable. 

□
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Video > Open video file… 
Video > Close video file 

Commands to open / close a video file to work on. 

This Open action doesn't perform the usual automatic opening of a Subtitle file possibly available on
the same directory, indeed to perform such action you'll have to act on the subsequent  Video > Open
second subtitle file… [see – see also the hereafter “Random-Bug” note], or on the File > Open commands [see],
which are anyway designed to take precedence over this very Open / Close action, and to act on both
Subtitle and Video files too. Reason is that  SE is primarily focused on editing Subtitle files, not on
playing Media. 

Possible “Error playing video file” means that the given file is not recognized as a proper Media file, or
simply that SE has not yet been assigned a proper media player52, as here suggested in Program Setup &
Management, section Management Actions [see]. 

Random-Bugs 
With a Video > Open video file… plus Open second subtitle file… sequence, on current SE rev. 3.6.2,

we've spotted some erratic/random Bugs:  

B1) Sound volume preset to zero-level. 

B2) In unchecked “mpv handles preview text” condition [see sct.:  (^) Play selection \ Text Permanence],
subtitles may appear or not, and at bottom on the actual video area, NOT on its bottom-dedicated stripe,
as it should in this condition. It will appear if, by chance, the same Subtitle file has been once formerly
called  at  first,  via  usual  File  >  Open command.  That's  the  typical  consequence  of  inaccurate
environmental parameters management. 

□

Video > Open video from url… 
S-PM 210900

 <Insufficient information> – Report suspended 
 With SE rev. 3.6.2 found always disabled. No further test without proper tech.info. 

□

Video > Open second subtitle file… 
S-PM 210500

Open a Subtitle file possibly second to the primary one, opened via the usual  File > Open main
command [see]. 

Remark 
Actually  not  one,  but  a  set  of  remarks—along  with  some  “Viewpoints”  too—from which  to

hopefully deduce the sense and utility of this command. 

52 Or “codec” (Code Decoder), as it is sometimes called by people loving to show how familiar they are with tech.jargon. 
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   A second Subtitle file presumably is to be compared with the primary one. 

   A primary Subtitle file may be opened also after a secondary one, in “(keep video)” mode [see]. 

   Command initially not available as a member of the “Video > …” menu, that is in SE “File > New” 
status [cf. figure]. 

 Becoming available only in presence of an opened Video file [cf. figure]. 

 <~> That to our constant perplexity, as the variability of menu composition is specific peculiarity of 
a context menu, not ordinary main menus'. 

   Second Subtitle file to be shown on the media virtual screen only. Title bar, List table, Text box, 
Soundtrack virtual monitor are all exclusively reserved to the primary Subtitle file. 

   In presence of a second Subtitle file only, such “Adjust” push buttons as “Play from just before text” 
and “Go to sub position and pause” are maintained inexplicably available, as in case of an ordinary 
primary Subtitle file, although, of course, ineffective. 
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   In presence of an opened second Subtitle file, this “Open second” command remains inexplicably 
still available, although, of course, ineffective. 

□

Video > Set video offset… 
As already considered [see term “Time”, at sct.:  Subtitles:  Terms & Concepts], Subtitles run during

intervals of time, all referred to the Media time. That means that the initial Subtitle time, the initial
starting point, is purely conventional, and usually conveniently set to zero. But, would it for any reason
be convenient to establish a starting point different from zero, this is the command for doing it. 

The case here considered is that of a video-media with a reference time-line not starting from zero, and
that's why the time-offset53 here considered is called “video offset”. 

video offset format:  hh:mm:ss.msec 

Relative … video position that is, not necessarily the beginning of the video 

Keep … codes <~> so said it's confusing, would become clear when used in a real case 
□

Video > SMPTE timing (drop frame)54 

 <Insufficient information> – Report suspended 
□

53 Offset, literally:  compensation. 
54 SMPTE - Society of Motion Picture and Television Engineers is a global professional association of engineers, 

technologists, and executives working in the media and entertainment industry. 
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Video > Generate/import scene changes… 

 <Insufficient information> – Report suspended [cf. also:  (^) Add scene change] 

□
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Video > Batch generate waveforms… 

 <Insufficient information> – Report suspended 

Activate a batch process which is operatively clear, but whose purpose and result is unknown to us. 

Input Options:  

, drag-n-drop input aimed at video files 

Scan folder…, Include sub folders  " 

Purpose:  

Generate waveform data <?> no idea what kind of data, whereto, what for. 

□

Video > Generate blank video… 
S-PM 210900

 <Insufficient information> – Report suspended 

Dialog box popping up at first call, citing a “FFmpeg” unknown to us55 [cf. next  Video > Generate video
with burned-in sub…]. To imply that, even before beginning to investigate about this command, we'll
need to know some preliminary basic-info about this whole matter, this command purpose, and so. 

□

55 FFmpeg – a suite of libraries and programs designed for processing of video and audio files. 
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Video > Generate video with burned-in sub… 
S-PM 210900

  <Insufficient information> – Report suspended 

Dialog box popping up at first call, citing a “FFmpeg” unknown to us. Even though the purpose of this
command could be fairly guessed from its caption, we'd rather postpone its analysis for the same reason
as expressed at the former “Video > Generate blank video…” command [see]. 

□

Requisite 
This command requires to operate on a given Subtitle file. 

Otherwise:  

<~> A requisite that we assume as so obvious that it seems to us more appropriate to simply disable the
command when not satisfied. 

□
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Video > Show/hide waveform 
Video > Show/hide video 
Video > Un-dock video controls 
Video > Re-dock video controls 

To modify  accordingly  the  named  areas  in  display  from the  initial  default  condition  [cf.  sct.:
Program Window & Context Menus] up to the new stated condition, and back. 

Here is  what  remains on the  SE Program Window when both Virtual  Screen and Main Tasks and
Soundtrack Monitor area are not in display. 

-<>-
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Synchronization Command Menu 

Command List 
Adjust all times (show earlier/later)… Visual sync… Point sync… 
Point sync via other subtitle… Change frame rate… Change speed (percent)
 

Requisite 

<.> Most of these Synchronization commands require to operate on a given Subtitle file. 
Otherwise: 

□

Synchronization > Adjust all times (show earlier/later)… 
Open a non-modal form aimed at “adjusting” the synchronization between Subtitles and speech. 

S-PM 210500

Non-modal means that this form's functionality is not exclusive, but momentarily added to that of the
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SE main window, so that the user may operate on both.  This means that resulting effects could be
immediately evaluated operating as usual on the  SE main window without exiting this  command's
session [<~>well, it may be not exactly so]. 

 Command currently under revision, therefore here described just AsIs [<~>oddities included]. 

Hour:min:sec.ms time interval to be subtracted / added to the Start time of the chosen contiguous set 
of Subtitle records [<~>default value may be disconcerting]; 

All lines / Selected / Selected and forward 
referred contiguous set of Subtitles records56 [<~>default status may be disconcerting]; 

Show earlier / later push button to immediately assign the chosen time shift; 

Total adjustment algebraic sum of the time intervals possibly entered [<~>unreliable, unexpected 
behaviors may happen]. 

Being so immediate and powerful a feature, here the Undo Ctrl+Z may come real handy. 
□

56 Of course here we don't deal with “lines”, but “records” [please cf.:  Subtitles:  Terms & Concepts; please do]. 
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Synchronization > Visual sync… 
Media time, that is:  media recording and playback time [see sct.:   Essentials \  Concepts \  Time],

normally is no SE's concern, in the sense that it isn't its business to define it. Its only related concern is,
if  ever,  to  position  the  subtitle's  timing—namely  Start,  Duration  and  consequent  End  time—with
respect to the media time assumed as a predefined and immutable data reference. Normally. But there
may be exceptions to that, in essence due to technical-historical reasons57, and generating a cumulative
discrepancy between the recording and playback timelines, not precisely identical, as they should be.
As a result, subtitles originally tuned, say, with the recording timing will result increasingly shifted at
playback execution. 

This command is provided to fix such discrepancy simply measuring the real playback time elapsing
between a scene, assumed as initial, and another, assumed as final. All Subtitle units in between will be
conveniently time-adjusted according to the reference interval of time actually measured this way. 

Disclaim 
The media image here shown doesn't correspond to a real case in which this command could be

properly used and tested. Indeed, we haven't even got such a real test-case [sorry]. 

57 Here just an hint about such reasons:  “Region” specific playback speed, not taking into precise account U.S. (Region 1) 
recording “frame rate” speed switched from 30 fps (frame/sec) of the Black-and-White films to the nowadays color 
29,97 fps films. 
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Controls 

 Subtitle record drop-down list 

Go to sub pos position the “Scene” at exact correspondence with the chosen subtitle record 

Ply 2 s and back short playback test (all other controls here assumed as self-explanatory) 

Sync “synchronize” all intermediate subtitles to the measured interval of time 
between the so defined Start and End scene. 

Remark 
The term “scene”, in the here-above “Start / End scene” captions, should not be interpreted—as

more usual—as interval of time, but instead as “instant of time”58, with the role of defining a playback
sequence, that is an interval of playback time. 

□

Synchronization > Point sync… 
 

 

<…> Command under investigation. Feature detected, so far:  

<.?.>  No clear idea what a “Sync Point” really is, in principle and functionally. More specifically:
what precisely are the actions here described as “adjust position” and “adjust speed”. 

Find text will open another “Find subtitle line” window, not requiring any further description 
being fully self-explanatory. Just a perplexity:  

58 <~> Therefore, our opinion, perhaps a more suitable term would have been “picture”, or even “frame”. 
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Viewpoint 
No clear evidence telling whether a given pattern has been found, or not, nor, and, when found,

what exactly has been found (e.g. looking for “unter” you may get the word “Untertitelung”). Which is
particularly tricky when the search-pattern falls outside of the text display-field, hence even, anyhow,
with no way to watch text beyond a rather limited length. 

Set sync point (and also double-click on a given Subtitle-line) will open another window with a 
possibly empty video display pane, where such a “Sync point” can be added, also 
without any video loaded. Here too this control-window is self-explanatory, but for 
the “Sync point time code” control, apparently showing what in the Subtitle table is 
called “Start time”. 

Sync point time code is the crucial “spin control” on this second window, where the current “Start 
time” value could be possibly changed to be then possibly overwritten on the related 
field. 
<.!.> grasped this functional aspect (to be said first...), this command can be fairly 
and fully explored. 

Set sync point push button control set on this second “Set Sync point” window, even with no actual 
Video loaded, will be accepted with no practical effect whatsoever but a record 
shown on the “Sync points” text-area. 

Showing that, whatever such Sync point is, it is associated to the #-count and Start 
time value of the pointed line. For what purpose it still to be understood. 
Figure here seen under text-field is assumed to show the time-difference between 
original and modified value. 

Apply Button that, when pressed, make the just inserted Sync point disappear from its text-
area, reason unknown. 

□

Synchronization > Point sync via other subtitle… 
Command to do the same job as with “Point sync…” but with reference to another Subtitle file

instead of a Video file <.?.>, all to be confirmed and tested <.?.>. 
□
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Synchronization > Change frame rate… 

 <Insufficient information> – Report suspended 

Command <.?.> all to clarify:  

Convert not “Change”, as in the command name and in the title bar? 

[…] button is to call a Video file, that is two of them:  all to clarify & test. 

□

Synchronization > Change speed (percent) 

 <Insufficient information> – Report suspended 
All to clarify:  

speed no idea what “speed of subtitle” means. About Subtitle records we know Number, 
Start/End time, Duration and Text. So, no idea what value/parameter is here going to 
be Adjust-ed or Change-ed, and for what reason; nor what is its original value. 

frame no idea what “From / To drop frame” means. 

lines presumably it stands for:  “Subtitle record” – to be confirmed. 
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Controls 

 <Insufficient information> – Report suspended 

<…> <…> 

-<>-
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Auto-translate Command Menu 

Command List 
Auto-translate… Auto-translate via copy-paste… 
Merge sentences… Break/split long lines… 
 

□

Auto-translate > Auto-translate… 
Auto-translate control form, requiring an active Internet connection. 

Service • Google Translate, combined free and “V1 API key” pricing policy, 80-odd languages;
• nikse.dk Multi Translator, from Swedish to Danish; crashes if no Internet connection 
[known bug, fixing is under way]. 

Line merge it's to make life easier to automatic translators, usually not liking sentences 
subdivided into distinct Records just for Subtitle's format reasons. Text sentences that,
after translation, may be split again between distinct Subtitle records just for the usual
good reasons. 
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Translate all default conditions accepted, then ignored this warning message. 

 Auto-translation example executed on a given short sample text. 

 <~> Text-boxes captions may appear inaccurate, as in the above example with:  
“Original text” on the wrong box, and a spurious “AltSinLinPix” label 
[notified bugs, fixing under way]. 

 <~> Original Subtitle file, even not edited at all, is curiously declared as modified 

 [notified bug, fixing under way]. 

 <.> At SE-Exit, translated Subtitle file is saved ok with a default name “video.de.srt”. 

□
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Auto-translate > Auto-translate via copy-paste… 
Similar to the preceding “Auto-translate…” command [cf.], provided to permit “manual” utilization

of possibly different automatic translators. 

Controls 
Max block size max. char.s extension of text-block to be submitted to automatic translators, in 

account of related possible limits. 

Line separator proposed char. to be assigned the role of Subtitle text unit separator59, to the benefit of
the automatic translation process. 

<~> Well, it works, but with a rather obscure and unfriendly UI, that should be drastically improved. 

□

59 As already stated throughout this Report, here too “line” is rather an unacceptably ambiguous, imprecise term [see sct.: 
Subtitles:  Terms & Concepts]. 
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Auto-translate > Merge sentences… 
Merge into one single Subtitle unit all sentences possibly spitted into distinct Subtitle text records,

with  usual  punctuation  as  full-stop  “.”  or  note  of  exclamation  “!”  are  taken  as  End-Of-Sentence
markers. 

For instance:  

will become:  

Remark 
Then, for a possibly inverse action, see next “Auto-translate > Break/split long lines…” command, all

that intended to the possible benefit of an automatic translation process. 
□
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Auto-translate > Break/split long lines… 
Inverse action of the preceding command [see], possibly useful to adapt automatic translations to

the usual Subtitle text formats [cf. first “Viewpoint” at sct.:  Chronicle of a basic “Create” experience]. 

-<>-
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Options Command Menu 

Command List 
Settings… Choose language… [English] 
 

□

Options > Settings… 

Here shown the list of all Settings… sections, with contents left to the direct User's experience, but for
some  items  treated  in  this  Report where  specifically  required.  As,  for  instance,  in  sct.s:   Shortcut
Commands, or Management Actions – Options > Settings… : Video player \ Video engine \ mpv [see]. 

Remark 
Enter Options > Settings… > Restore default settings > OK to restore SE's initial defaults. 

□

Options > Choose language… [English] 
Choose  the  SE's  User  Interface  language,  and  alphabet,  among  30-odd;  with  shown  current

[default]. 

-<>-
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Networking Command Menu 

Requisite 
<.> An active Internet connection. 

SE-Networking then provides a collaborative tool among SE-users, connected in Internet. 
□

Typical SE-Networking Session 
As initial Networking action enter a “Start new session” command [for or all details about this and

other Networking commands see next sections], just accepting all default values shown on the “Start network
session” control box. This way, current SE-workstation assumes a Master role on the just born  SE-
Networking session:  let's call it the “Session Starter” workstation. A look at the “Show session info and
log”, so to verify all about it. 

Then you may activate a second SE-instance on the same computer as a convenient way for emulating,
and testing, an actual SE-Networking operative condition. On it, preset a nice clean “File > New” status,
then enter a “Join session” command accepting all default parameters offered, but the Username to which
a  “-J1”—standing  for  “Joiner  1”60—should  be  post-fixed,  so  to  conveniently  characterize  it.  Then
possibly a “Show session info and log” on each SE-instances, so to verify all about the new configuration.

<!> Here, in particular, one crucial parameter is to be considered:  the “Session key”. That is, the logical
link for the hand-shaking process between the two SE-workstations now connected in Network. 

60 Here we'd rather talk of “Session Starter” and “Session Joiner”, instead of using the standard Master–Slave terms. 
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In a “real” case, with physically distinct and remote SE-Workstations, this crucial parameter should be
communicated by means of such a media as E-mail,  or so. Anyway, now the two  SE-Workstations
enjoy the following condition:  now Mr. “Starter” and “Joiner can:  

<!> communicate via “Networking > Chat” [see]; 

<!!> share  the  very  same  SE-Subtitle  job,  so  to  collaborate,  for  instance—and  typically—on  a
translation [cf.:  ToggleTranslationMode (Control+Shift+O), sct.:  Shortcut Commands List]. 

 Indeed, as said, a nice collaborative tool among SE-users, connected in Internet. 

-<>-
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Command List 
Start new session Join session 
 

□

Networking > Start new session 
Made an initial (and necessary) test-experience with the “Join session” command [see above], now

we endeavored this “real” one, 

where the only remarkable difference we see is the “Generate new key”, whose role is now so obvious
that there is no need to test it. So then, a nice “Start” and what we see is that the Networking menu
changes this way:  

Command List 
Chat Show session info and log Leave session 
 

□

Networking > Chat 
Started a new SE-Networking session, entered this command, here the resulting situation:  
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<~> about which we observe:  

• From what so far seen, it seems that a “Chat” is the only SE-Networking activity available. We 
presume it is not so, therefore further investigation is in order. 

• Besides, here a “Chat” seems permitted with only one interlocutor. Obviously here too further 
investigation is in order:  
<.> It's what we intend to do and describe with the next “Two SE-Instances” section [see].

□

Networking > Show session info and log 

This is how to inspect all about an SE Networking session under way. 
□

Networking > Leave session 
Reset condition as before entering “Start new session” command61. 

61 <!> As all “Sorcerer's Apprentice” should know, the first thing to learn about a new and unknown operative condition is 
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□

Networking > Join session 
First command we'd endeavor to test. 

Username we'd take it as automatically proposed by SE, so to identify the connecting user. 

Session key same as above, for the current operative session. 

Webservice URL drop-down list offering two choices, beyond an initial default one. 

 Here is what happened trying to use each one of them. 

https://www.nikse.dk/api/SeNet 
This is what happened trying to “Join” this default URL:  

 From which we infer:  
 • A valid “Session key” should be known in advance. No “search” available. 
 • The “Session key” here offered as default is presumably for initiating a new session. 

 <~> Anyhow, an initial default URL that curiously “despairs” after possibly selecting 
one of the other item in list. To regain it we had to undergo a general Options > 
Settings… > Restore default settings > OK 

how to safely leave it. 
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□

https://www.nikse.dk/se/SeService.asmx 
This is what happened trying to “Join” this one:  

https://se-net.azurewebsites.net/SeService.asmx 
and here trying to “Join” the other:  

 Obvious conclusion:  
<.> We'll proceed our inquiry relying only on the initial default URL. 
<?> Support anyhow badly needed about this entire subject.- 

-<>-
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Help Command Menu 

Command List 
Check for updates… Help About 
 □

Help > Check for updates… 
Command requiring an active Internet connection, so to check if there is available any SE program

version / revision more recent than that currently in use. 
□

Help > Help 
Command requiring an active Internet connection, so to display the SE-Help tech. info as currently

available on the https://www.nikse.dk/SubtitleEdit/Help web site page. 
□

Help > About 
S-PM 210800

Designed to display this SE program’s identity card, with some basic reference information62. 

-<>-

62 Just a reminder:  SE program and SE Tech.Report authoring references can here be found at sct. Essentials [see]. 
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Shortcut Commands 
S-PM 210800

Not all is “Object Oriented” interaction with SE, there are also some old-fashion “Command Oriented”
interactive  actions  that  the  user  may require  via  precise  keyboard  stroke  combinations,  of  course
provided he knew them in advance, given the fact that such sort of textual commands are not kindly
offered to be chosen within a drop-down Menu command list [cf. sct.:  Main Command Menu], or a pop-
up Context command list [cf. sct.:  Program Window & Context Menus]. 

Here we are not talking about such sort of shortcuts as, for instance, a “Ctrl+N”, shown beside its parent
“File > New” command [see], simply as a convenient quick alternative for calling its very same parent
command. What we are considering in this section are commands for which there is no other way to
call them, but via the keystroke sequence as hereafter described63. Keystroke sequences defined in the
Options > Settings… : Shortcuts form [see], there available to be explored, and possibly customized64, 

and also Export-ed as a markup “SE_Shortcuts.xml” file [cf.:  Shortcuts pop-up menu]. 
□

Viewpoint 

To investigate, test and then describe this particular set of commands we had first to overcome
some structural difficulties that we consider worth describing in detail [see next sct.:  Marshalling Shortcuts
File], so to hopefully attract the attention of the  SE developers possibly interested in remedying the
situation, being convinced that a remedy is badly needed. 

63 Actually, more a quirky combination of keys than a clean textual string, or abbreviation. 
<.> By the way, consider in particular that “Fn” Function Keys may require an extra key stoke to use them as 
SE-Shortcut, instead of as a so called system “Hotkey”. 

64 A possibility here not described, as off-scope for this Report. 

 – 130 –  



Subtitle Edit Shortcut Commands  Technical Report

Shortcut Commands List 
List of “pure”  SE interactive commands, extracted from the currently standard “SE_Shortcuts.xml”

file65, excluding all shortcuts associated to a parent Menu or Context command, keeping the original
order and “.xml” tag-sections [that is:  <General, <Main, <Waveform]. 
<General 
GoToFirstSelectedLine Control+L 

Scroll the List view table so to display the first Subtitle row of a possibly long 
sequence of selected rows. 

ToggleTranslationMode Control+Shift+O 
A “Translation Mode” not so so simple to enter, as far as we could see. In wait for 
better tech. info [<.?.> investigation is under way] this is how we managed it. 
‣ Assuming to have got an original Subtitle file, say Dummy8.srt, that we'd like to 
translate into a different language, say German, first action was to create a target 
Subtitle file conveniently named “Dummy8.De.srt”. 
‣ Our first idea was to create an empty “…De.srt” file on which then to work upon 
operating, indeed, in SE “Translation Mode”. But that revealed impossible, for many 
curious reasons. Just one:  SE disdains either creating or opening empty or short 
Subtitle file, with such reason as:  “File is empty or very short!” [“So what, it's none of your 
business”, our reaction was]. 
‣ Anyway, to circumvent such difficulty we simply copied just the first original 
Subtitle record into the new file, and translated it off-line. Then, opened it, we entered
the here considered shortcut command so to activate the desired “Translation Mode”, 
successfully. Here the result:  

 Not bad, one can begin translating ok. But we're not sure that's how we are really 
supposed to operate. <.?.> Therefore a related investigation is still underway. 

65 Currently, that is:  rev. 3.6.2 
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Remark 
Apart from the “Toggle” aspect [<~> and the naming difference:  Translation vs.  translator], this Shortcut

command seems identical to the Main menu  File > Open original subtitle (translator mode)… command
[see], included the odd meaning assigned to the “original” qualification, as there expressed, and here
confirmed. 

□

MergeOriginalAndTranslation Control+Alt+Shift+M 
It is to “merge” original and translated texts into a different Subtitle file, so to 
possibly display subtitle texts of both languages together. 

GoToNextSubtitle Shift+Return 
Go to next Subtitle row on the List view, select it and scroll [List view only, not the 
Soundtrack's Waveform, alas]. 
<?> But then, if you try to start playback, say via a “Control+P” action [see], record 
selection will be reset back to the position before this “Shift+Return” action. 
<?> Sounds as a bug. 

GoToNextSubtitlePlayTranslate / GotoPrevSubtitlePlayTranslate 
Alt+Up / Down [▲ / ▼ arrow] scroll select one row up / down66 

<OpenDataFolder> Control+Alt+Shift+D 
<?> No idea what it is about – sounds as cast off. 

□

<Main 
ToolsFixCommonErrorsPreview Control+P 

Operates only at Step 2/2–“Verify fixes” of command Tools > Fix common errors… [see]. 
<?> Besides:  this same “Control+P” shortcut is here assigned also to the command 
“VideoPlayPauseToggle”. Sounds as a bug. <?> 

EditInverseSelection Control+Shift+I 
Invert current Subtitle Record selection on the List view and Soundtrack's Waveform.

VideoPause Control+Alt+P 
Pause video playback. <~> Forget it, use instead the much more convenient toggles:  
<!> Control+P, or the equivalent (^)-“Click-action” directly on the very Virtual Screen. 

VideoPlayFromJustBefore Shift+F10 
Start Playback just before the currently selected Subtitle Record [about 1/2 sec]. 

VideoPlayPauseToggle Control+P Toggle Playback (play/pause). 
<?> This same “Control+P” shortcut is here assigned also to command 
“ToolsFixCommonErrorsPreview” [cf.]. Sounds as a bug. <?> 

66 <.> Same selection performed on the Soundtrack too, a double-click to synchronize Position marker. 
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Video500MsLeft Alt+Left [◀ arrow] Shift Position marker 
Video500MsRight Alt+Right [▶ arrow]  " 
Video3000MsLeft F7   " 
VideoGoToStartCurrent F6  Shift at Start of 1st selected Unit 
VideoToggleStartEndCurrent F4   " toggle at Start/End of 1st selected Unit 

VideoPlaySelectedLines F5 should Playback all possibly selected contiguous Units, but it 

is still  <Under Revision>, as it doesn't operate as designed do to. 

VideoFullscreen Alt+Return 
Toggle Virtual Screen Full/normal (equivalent “esc” to normal) 

VideoReset Control+D0 [Decimal 0] 
Reset Virtual Monitor status:  100% Zoom and Play rate (speed). 

ListViewGoToNextError F8 
Go and select next faulty Subtitle record after the currently selected one, if any. 
No wrap-around. 

TextBoxSplitAtCursor Control+Alt+V 
Split current Subtitle record at the current text insertion point on the Text box. 

TextBoxSelectionToLower Control+U selected text on the Text box to:  lower case 
TextBoxSelectionToUpper Control+Shift+U  " to:  UPPER case 
TextBoxSelectionToggleCasing Control+Shift+F3  " toggle to:  UPPER/lower/Proper case67 

CreateInsertSubAtVideoPos Shift+F9 
insert a Subtitle record at current Position marker 
(take care:  not within an existing Subtitle). 

AdjustSetStartAndOffsetTheRest Control+Space 
set Start time of current selected Subtitle record at Position marker, and shift 
accordingly all the subsequent ones. 

AdjustExtendToNextSubtitle Control+Shift+E 
extend End time of current selected Subtitle record to the next one. 

AdjustExtendToPreviousSubtitle Alt+Shift+E 
extend Start time of current selected Subtitle record to the previous one. 

InsertAfter Alt+Insert 
insert a Subtitle record after the currently selected one. 

TextBoxAutoBreak Control+R 
same as with “Auto br” button on the Text box [see]. 

WaveformInsertAtCurrentPosition Insert 
insert a Subtitle record at current Position marker (avoid withing an existing one). 

67 “Propercase”:  First letters Up, all other low. Ctrl+Z to regain original format. 
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InsertBefore Control+Shift+Insert 
insert a Subtitle record before the currently selected one. 

□

<Waveform 
VerticalZoom Shift+Add Vertical Zoom commands for Waveform [presumably], 
VerticalZoomOut Shift+Subtract it requires a Numeric pad [that we don't have]. 

AddTextHere Return [←just “Return”, simple and powerful] 

Insert a new Subtitle, and text, on a selected void Timeline segment. 

100MsLeft Shift+Left [◀ arrow] Shift Position marker 
100MsRight Shift+Right [▶ arrow]   " 
1000MsLeft Left [◀ arrow]   " 
1000MsRight Right [▶ arrow]   " 

Viewpoint 
It's rather odd that so similar [◀ arrow ▶] commands are located into so different sections “<Main”

and “<Waveform” [see]. 
□

Other Shortcut Commands 
SE recognizes  a  few  other  useful  shortcuts  commands  beyond  those  defined  into  the

“SE_Shortcuts.xml” file—as here above considered [see]—and those associated to ordinary menu and
context commands. 

On the List view:  

Ctrl+V single or multiple [via:  kept pressed] insert of a previously copied Record [via:  Ctrl+C or
(^) Copy as text to clipboard], with all Records time fields conveniently recalculated. 
Of all traditional and well known shortcuts—such as:  Ctrl+X, +Y, +Z—we'd here 
recall this one, as particularly powerful and useful for appending dummy Records at 
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the bottom of a Subtitle file. 
Beware:  Overflow condition not detected [cf.:  (^) Insert subtitle after this line…]. 

Shift+Up / Down [▲ / ▼ arrow] add select one row up / down 

Ctrl+A  select all Subtitle rows, and records [hint, to deselect all:  
 EditInverseSelection (Control+Shift+I), or even simpler:  click an empty row] 

□

Viewpoint 
As said,  “SE_Shortcuts.xml” markup file holds mixed sets of both “traditional” shortcuts,  that is

those associated to a parent  Menu or Context  command—such as “Ctrl+N”,  shortcut  version of its
parent “File > New” command—together with sets of “pure”  SE interactive commands, that is those
described in the above “Shortcut Commands List” section. Well, we find it rather confusing, and would
suggest to introduce two distinct “.xml” tag-sections for such rather distinct sets. 

Besides,  we realized that  the set  of  “pure” Shortcuts  here considered are rather  useful  in  two
distinct  SE-operative areas:  Subtitle editing [e.g.:  CreateInsertSubAtVideoPos (Shift+F9)] and playback
[e.g.:   VideoPlayPauseToggle  (Control+P)].  Therefore,  instead  the  inexpressive  current  subdivision  in:
<General, <Main, <Waveform, we'd rather adopt a more rational <Editing and <Playback tag-sections. 

□

Final Remark 
There can be counted five different ways of user interaction with  SE,  as described in different

sections of this Tech.Report. 

I1) Usual Menu commands [see sct.:  Main Command Menu] 

I2) Context commands [see sct.:  Program Window & Context Menus] 

I3) Shortcut commands [see this very sct.:  Shortcut Commands] 

I4) Extra Shortcut commands [just last sub-sct., here above] 

I5) Usual manual control actions, as:  push, drag, resize, click, …; [examples offered throughout this Report, 
 particularly with sct.s:  Basic Tasks and Main Tasks and Soundtrack Work Area].- 

□

Marshalling Shortcuts File 
Of course there is a substantial difference between shortcuts corresponding to ordinary “full size”

commands [e.g.:   “File > New”,  shortcut:   “Ctrl+N”] and “pure” shortcuts commands [e.g.:   VideoReset
“Control+D0”] for which the very shortcut is the only way to execute them. It is therefore obvious that
to intermix them into the same “SE_Shortcuts.xml” file—as it is now68—is an annoying and error-prone
source  of  confusion.  To overcome this  basic  difficulty we carried  on the  following “Marshalling”
actions:  

M0)  Export… the original “SE_Shortcuts.xml” file, made then a work-copy to be conveniently edited. 

68 That is:  SE rev. 3.6.2 
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M1)  Delete all “unnecessary” markup tags, keeping then only the section names [as:  <General], 
shortcut captions [as:  GoToFirstSelectedLine] and codes [as:  Control+L]; all in the 
original list order. 

M2)  Delete all entries ending with a trailing “ />”, that is entries with no shortcut code associated 
[e.g.:  <Plugins />]. 

M3)  Mark with a leading “-” minus all items associated with ordinary SE menu or context 
commands [e.g.:  - Help  F1, or:  - FileNew  Control+N]; and that done “simply” 
scanning all of them, hoping not to have overlook any one. 

M4)  Collect only and all “pure” shortcut into a dedicated list, as the subject of this very “Shortcut 
Commands” section. 

□

Anyway, 
here is the resulting table, where some residual minor oddities can be spotted, as captions out-of-

place, [as:   WaveformInsertAtCurrentPosition not  into  <Waveform  section, but in  <Main instead],  or
such similar [◀ arrow ▶] items split between such different sections as <Main and <Waveform; and the
like. 
<General 
 GoToFirstSelectedLine Control+L 
- MergeSelectedLines Control+Shift+M 
 ToggleTranslationMode Control+Shift+O 
 MergeOriginalAndTranslation Control+Alt+Shift+M 
 GoToNextSubtitle Shift+Return 
 GoToNextSubtitlePlayTranslate Alt+Down 
 GoToPrevSubtitlePlayTranslate Alt+Up 
- ToggleBookmarksWithText Control+Shift+B 
?   <OpenDataFolder> Control+Alt+Shift+D 
- ToggleView F2 
- Help F1 
 
<Main 
- FileNew Control+N 
- FileOpen Control+O 
- FileSave Control+S 
- EditUndo Control+Z 
- EditRedo Control+Y 
- EditFind Control+F 
- EditFindNext F3 
- EditReplace Control+H 
- EditMultipleReplace Control+Alt+M 
- EditGoToLineNumber Control+G 
- EditRightToLeft Control+Shift+Alt+R 
- ToolsFixCommonErrors Control+Shift+F 
 ToolsFixCommonErrorsPreview Control+P 
- ToolsRenumber Control+Shift+N 
- ToolsRemoveTextForHI Control+Shift+H 
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- ToolsChangeCasing Control+Shift+C 
 EditInverseSelection Control+Shift+I 
 VideoPause Control+Alt+P 
 VideoPlayFromJustBefore Shift+F10 
 VideoPlayPauseToggle Control+P 
- VideoShowHideVideo Control+Q 
 Video500MsLeft Alt+Left 
 Video500MsRight Alt+Right 
 Video3000MsLeft F7 
 VideoGoToStartCurrent F6 
 VideoToggleStartEndCurrent F4 
 VideoPlaySelectedLines F5 
 VideoFullscreen Alt+Return 
 VideoReset Control+D0 
- SpellCheck Control+Shift+S 
- SpellCheckFindDoubleWords Control+Shift+D 
- SpellCheckAddWordToNames Control+Shift+L 
- SynchronizationAdjustTimes Control+Shift+A 
- SynchronizationVisualSync Control+Shift+V 
- SynchronizationPointSync Control+Shift+P 
- ListViewItalic Control+I 
 ListViewGoToNextError F8 
 TextBoxSplitAtCursor Control+Alt+V 
 TextBoxSelectionToLower Control+U 
 TextBoxSelectionToUpper Control+Shift+U 
 TextBoxSelectionToggleCasing Control+Shift+F3 
 CreateInsertSubAtVideoPos Shift+F9 
- CreateSetStart F11 
- CreateSetEnd F12 
 AdjustSetStartAndOffsetTheRest Control+Space 
- AdjustSetStartAndOffsetTheRest2 F9 
- AdjustSetEndAndGotoNext F10 
 AdjustExtendToNextSubtitle Control+Shift+E 
 AdjustExtendToPreviousSubtitle Alt+Shift+E 
 InsertAfter Alt+Insert 
 TextBoxAutoBreak Control+R 
 WaveformInsertAtCurrentPosition Insert 
 InsertBefore Control+Shift+Insert 
 
<Waveform 
 VerticalZoom Shift+Add 
 VerticalZoomOut Shift+Subtract 
 AddTextHere Return 
 100MsLeft Shift+Left 
 100MsRight Shift+Right 
 1000MsLeft Left 
 1000MsRight Right 
 
<Main 
- AutoTranslate Control+Shift+G 

□

 – 137 –  



Subtitle Edit Shortcut Commands  Technical Report

<.> This is the list of “pure” interactive SE shortcut commands on which we've based this section's 
drafting. Of course, we're not sure it's perfect, therefore SE people's evaluation here is more welcome 
than ever. 

-<>-
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Program Setup & Management 
S-PM 210500

Reference section for SE program setup and management. 
□

Environment and Resources 
Reference  platform  Microsoft  Windows69 and  program  Subtitle  Edit are  as  detailed  in  section

Essentials, table Version Reference [see]. About other required resources:  

 Internet connection, not only for the initial SE program down-loading, and possibly successive 
Help > Check for updates…, but also for such usual operative circumstances as with:  Auto-translate
> Auto-translate… and Help > Help commands [see]. 

 Rather useful, practically indispensable, an auxiliary media player program such as the popular
 [our choice]. That beyond the “MPV Media Player” (a “.dll” library) as in next 

Management Actions section [see]. 

□

Initial Setup Actions 
Extremely smooth, no hassle initial setup and start up actions [ver.:  3.6.0]. As a result you'll get a

“Subtitle Edit” directory into the standard Windows “Program Files” directory, and a “Subtitle Edit” folder
available  under  the  usual  Desktop  >  Start button;  to  run  the  very  “SubtitleEdit.exe”  program:

 [see also inside:  Changelog, Online Help, Subtitle Edit on the Web, and Uninstall Subtitle Edit]. 

 Then we've found convenient to create also an usual “Pin to Start” shortcut. 
□

Experience of Subsequent Updating 
S-PM 210800

SE Help > Check for updates… to get news about the availability of subsequent SE revised issues,
such as the currently latest SE rev. 3.6.270 (24th Aug 2021), “Changelog” included. 

69 About possible other platforms, on its very web site SE is declared “a Windows program [that] runs (mostly) well on
Linux via Mono.” [see]. 

70 Distinct terms:  “Version” and “Revision”, with such abbreviations as:  ver. 3.6, rev. 3.6.2 
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Viewpoint 
“Changelog” certainly useful for evaluating announced novelties, just a little cryptic for ordinary

users, possibly not  SE–program developers. For instance, probably here not everybody knows what
“ASSA” stands for [probably:  “Markup Tags”, but we don't know for sure]. 

□

Actions 
On the  SE web site  https://www.nikse.dk/, section  Download, a  Subtitle Edit 3.6.n link brings us to:

https://github.com/SubtitleEdit/subtitleedit/releases, where we may choose to download:  SubtitleEdit-3.6.n-
Setup.zip 

That is, an 8 MB file, with practically no size difference between the “.zip” and the expanded 
“Setup.exe” file. Then, with Internet disconnected, now not required:  
 4 As (Local) Admin, “over” the currently installed SE program (that is, no need to Uninstall it); 
 4 Run Setup, Select:  English, all components & defaults accepted, but the desktop shortcut, refused. 
 4 Associate SubRip Text (.srt) files with Subtitle Edit. 
 4 A short waiting, then Finish and Restart. That's all.- 

This way, last SE rev. 3.6.(2) is up and running, with the preceding SE “pinned” start icon still working
ok. What may be not working is the expected SE–“.srt” file Open-automatism. Easily fixed by hand. 

□

Current Setup Details 
 As a rule, this Report is about final SE release, not “alpha” nor “beta” preliminary versions. 

About precisely which release version, please see sct.:  Planned Revision and Update. That is to 
realistically say that current Report may be not updated up to the latest SE rev. in use. 

 SE is compiled “Any CPU”, where Any means that it can run as well on a 64 or 32 bit Microsoft
h/w platform [appreciable compatibility]. 

 Both the usual “... Setup.zip” Installer [our choice] and a “SEnnn.zip” Portable [declare also Linux 

compatible] version are available. 

 Notice that SE command Help > Check for updates… offers information only, no automatic 
update actions. 

□

Management Actions 
In this section we'll take note of the management actions subsequently suggested, or required, by

our experience of use. 

Options > Settings… : Video player \ Video engine \ mpv 
to enable “mpv” as the SE Video media player71, as here suggested. An action that 
cannot be possibly performed before installing SE. 

71 Or “codec” (Code Decoder), as a it is sometimes called by people loving to show how familiar they are with tech.jargon.
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<.> Other choices may be:  VLC (Media Player) or LAV filters. 

Options > Settings… > Restore default settings > OK buttons72, 
to reset the initial default setting and condition, File> Reopen history included [see]. 
Same result can be obtained deleting the “Settings.xml” file you'll find in:  
…\Users\myUserName\AppData\Roaming\Subtitle Edit 

S-PM 210800

<…> Nothing else, to date.- 

-<>-

72 “Restore” button acts on the Settings form only, “OK” is to transmit the action to the SE program. 
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□

Cross-reference 

<.> With this Tech.Report available as a “.pdf” file it is rather convenient to use the usual Search /
Find text commands as Cross-reference tool. So convenient, that we haven't considered worth adding
also a traditional Cross-reference section to this Table of Contents.- 

=<>=
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Appendices 
S-PM 210400

Graphical User Interface (GUI) Glossary 
Glossary of specific terms used throughout  this  Report73 referring to items on the  SE program

Window, here listed in inclusion order. Terms usually written with initial capital letter, so to recall their
conventional meaning and role as element of the Graphical User Interface (GUI) language. 

□

Window top graphic operative structure of an application on the Desktop, that is the computer 
screen. 

Area generic term for a specifically identifiable subdivision into a Window. Term 
particularly useful to identify a coherent set of task-oriented elements. 

Bar Window frame stripe, for such elements as:  Title, Icon-Tools, Menu. 

Pane main adjustable rectangular subdivision of the work area within a Window, to host 
specific Controls and Forms. 

Control Generic name for such elements as:  button, command, selection check-box, option 
round-box, list-box, … 

Caption visible title or name assigned to a Control, a term derived from journalistic jargon. 
With menu items there is no distinction between the Control in itself and its title, as 
they are the same thing. 

Dialog Box or simply Box, a secondary Window for specific user interactions. Likewise, just a bit 
more specific:  Control-, Error-, Tool-, Alarm-, Hint-Box. 

Form Homogeneous area of a Window, sub-Window or Pane, organized for a specific task; 
typically with controls and labeled fields to be filled with data. 
<.> Functional hierarchy recognized in this Report:  Window > Form > Box. 

Text Form Where to write texts by means of a so called Text Editor. 

Tab A control for selecting one among possibly different overlapping Forms. In a Tab, if 
the case, you may distinguish Tab-label and Tab-page areas. 

-<>-

73 Whose number we feel committed to contain in fair balance between clarity and redundancy. 
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Typographical Conventions 
Prevalent typographical conventions here adopted to increase readability. 

S-PM 210400

Arial titles as:  Technical Report, names as:  SE – Subtitle Edit, section headings as:  
Typographical Conventions 

Times New Roman standard Report's sections text, including in-text notes 

Source Code Pro inscriptions, such as page number “- 106 –” and section's edition date-code 
 S-PM 21040074 

Segoe UI standard User Interface items, such as:  URLs https://www.nikse.dk, file paths 
C:\Dir\Subdir\fileneme.ext, captions Video position, command buttons Open; 

Italics for special text-segments, as short in-text [notes], or within a Segoe UI string, referring 
to a replaceable/variable item, such as a generic filename.ext into a standard path:  
C:\Dir\Subdir\fileneme.ext 

Capitalized terms with the initial capitalized not only for proper names, such as:  Windows, 
Subtitle Edit, but also to qualify terms to be intended in a specific technical sense, 
such as:  Gap, Tag, Record. 

Remark 

<~> To be extra-precise such “Options > Settings…”, when intended as an SE command, should be
typed with font Segoe UI, whereas, when intended as the title of the related Report's section, should be
typed with font Arial. But, frankly, our love for formal accuracy doesn't go so far, and we'll generally go
in favor of a generic Arial, leaving to you the burden of interpreting it strictly as a command, or as the
section describing it, or both. 

□

Viewpoint ← special section expressing a specific Author's opinion, such as:  
Unfulfilled requisite could be a nice good reason to dim-disable the related command [an Author's

opinion, disputable]. 
□

  > Separator for menu command path, e.g.:  Help > About 

  :  \  \ subsequent separators within a form, as with Options > Settings… : Video player \ Video 
engine \ mpv – actually, a path to a given control within a form. 

 … \ leading path left implicit, as with standard Windows …\Program Files 

 (^) “click” action symbol, for context pop-up menu, e.g.:  (^) Play selection 

74 <!> Just to recall how relevant this convention is:  sections marked with a successive edition date-code are intended to 
supersede all preceding ones. 
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 <.> Point deserving special attention – as:  
 <!> Remarkable point 
 <?> Questionable point 
 <~> Perplexity, doubt, suggestion 
 <…> Ellipsis, for topic still to be completed 
 <.?.> Questionable point, still under investigation 
 <ToBeCompleted> – self-explanatory disclaim 

□

Icons for:  Obstacles to the authoring of a valid Tech.Report 

  <Under revision> – Report left AsIs 

  <Insufficient information> – Report suspended 

  <Not covered> – Off-Report 
□

Abbreviations:  cf. confer – compare with 
cmd command 
e.g. exempli gratia – for example 
i.e. id est – which is to say 
ref. reference / refer to 
sct. section [symbol:  § ]. The term “section” is here deliberately adopted to 
 signify any generic subdivision of text, be it chapter, paragraph, or 
 sentence. 

[see: ...] typical in-text short note, intentionally more immediate than a traditional footnote.- 

-<>-

Planned Revision and Update 
S-PM 210500

SE Technical Report has been conceived as a “dynamic” structure, with a planned mechanism of revision
and updating. Reasons for that are:  

 SE evolves with time; 

 SE deals with too many and different aspects to be all well covered just in one shot; 

 Community of  SE users  is  a  continuous source of  remarkable experiences  and news worth
knowing. 

This the envisioned mechanism of revision and update. 
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 SE Tech.Report is made available on-line [see:  What & Where in the Internet, sct. Essentials], so to
constantly offer its current version, no delay; 

 Single sections may be prefixed with such a code-mark:  S-PM 210500 [cf.]
that is, the Author's ref. acronym “S-PM” followed by a “yymmdd” numeric date-code, to signify
that a section marked with a more recent date-code is intended to supersede the preceding one.
As simple as that. 

 Some section can currently be nothing more than a place holder, that is just a title followed by
such disclaim as:  

 <Insufficient information> – Report suspended 

 New and different sections may be added to the Report. In that case the very first code-mark on
top of the Report cover page [see] will be updated. 

There is a reason for all that:  To make anyhow available in time a hopefully valid Report, even though
not perfect, without waiting to make it perfect in a far and improbable future75. 

=<>=

75 In that inspired by the wise statement:  “Well, nobody's perfect.” 
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